Bug 12758 - boot fails during fsck in rc5.d sequence
boot fails during fsck in rc5.d sequence
Product: Red Hat Linux
Classification: Retired
Component: e2fsprogs (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Florian La Roche
Depends On:
  Show dependency treegraph
Reported: 2000-06-20 10:48 EDT by greg sahli
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2000-08-11 09:25:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description greg sahli 2000-06-20 10:48:55 EDT
I have a CTX Cyrix/200; the dedicated linux drive is a 3 Gig Maxtor IDE, 
with a BIOS add-on called EZBIOS. I use loadlin because this BIOS has to 
load before linux boot -- and I like the config.sys dual boot technique.
I use just two partitions (/ and swap).
RedHat 5.2 and 6.0 both work well with this setup -- except that I remember
always getting (during the rc3.d or rc5.d init sequences): "root is mounted. 
WARNING - running fsck on a mounted filesystem can cause severe dammage. -
Check aborted."  After this, the remainder of the boot was OK.
After trying Upgrade to 6.2 first, and a complete 6.2 install next, the boot 
sequence fails at the fsck with this message: "Root is mounted. (or maybe it 
says Root is mounted as /dev/hdb1). CANNOT CONTINUE. Dropping you to a 
shell."  From the shell, I run fsck and I get result code 8 -- "operational 
failure," so I understand why it stops the boot.  But I think the fsck 
result is bogus.
Additional troubleshooting: Reinstalled RH 6.0, works fine. Installed RPMS 
for e2fsprogs from RH 6.2 disk(one or two others required for dependencies, 
initscripts was one, for example). Rebooted. Boot failed at exactly the same 
place, fsck.  Something has changed that is incompatible with my system.
Thanks for your effort.
Comment 1 Jeff Johnson 2000-08-09 13:58:05 EDT
Why do you thin the result code is bogus?

Have you tried running fsck manually? What messages were displayed?
Comment 2 greg sahli 2000-08-11 09:25:07 EDT
from sahlgre:
When I run fsck manually using vers. 1.18 (I believe that's the one in RH 6.2),
I get result code 8 and fsck refuses to attempt fixes.

When I run fsck vers. 1.14 (in RH 6.0), I get code 4 if just asking for codes, 
or, I get several >fix (y/n)< dialogs with the following types of errors typical:
duplicate/bad blocks (usually two or three of these);
block bitmap differences (a few);
free blocks count wrong for group #_ (a few).

I am speculating that the error code 8 with vers. 1.18 is bogus since vers. 1.14 
can fix these problems.
Comment 3 Florian La Roche 2001-05-16 03:55:11 EDT
Something is wrong on your system if the root filesystem is already mounted
read-write during the filesystem check. If older tools don't warn or stop, this
would also be a bug in older rpms.

Current rpms seem to do the right thing, so I'll close this bug.

Note You need to log in before you can comment on or make changes to this bug.