Bug 1275835 - SELinux is preventing /usr/bin/systemd-ask-password from read access on the file environ
SELinux is preventing /usr/bin/systemd-ask-password from read access on the f...
Status: CLOSED DUPLICATE of bug 1268668
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-27 17:50 EDT by Germano Massullo
Modified: 2015-12-02 09:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-02 09:00:57 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Germano Massullo 2015-10-27 17:50:38 EDT
Description of problem:
# journalctl -xe
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- 
-- L'unità httpd.service è fallita.
-- 
-- Il risultato è failed.
ott 27 22:45:02 host systemd[1]: Unit httpd.service entered failed state.
ott 27 22:45:02 host audit[1]: <audit-1130> pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=httpd comm="systemd" exe="/usr/lib/systemd/systemd" host
ott 27 22:45:02 host systemd[1]: httpd.service failed.
ott 27 22:45:02 host polkitd[871]: Unregistered Authentication Agent for unix-process:2969:368658 (system bus name :1.66, object path /org/freedesktop/PolicyKit1/AuthenticationAgent, loc
ott 27 22:45:03 host org.fedoraproject.Setroubleshootd[798]: 'list' object has no attribute 'split'
ott 27 22:45:03 host setroubleshoot[2987]: Plugin Exception restorecon_source
ott 27 22:45:03 host setroubleshoot[2987]: SELinux is preventing /usr/bin/systemd-ask-password from read access on the file environ. For complete SELinux messages. run sealert -l cc36ce9
ott 27 22:45:03 host python[2987]: SELinux is preventing /usr/bin/systemd-ask-password from read access on the file environ.
                                   
                                   *****  Plugin catchall (100. confidence) suggests   **************************
                                   
                                   If you believe that systemd-ask-password should be allowed read access on the environ file by default.
                                   Then you should report this as a bug.
                                   You can generate a local policy module to allow this access.
                                   Do
                                   allow this access for now by executing:
                                   # grep systemd-ask-pas /var/log/audit/audit.log | audit2allow -M mypol
                                   # semodule -i mypol.pp
                                   
ott 27 22:45:09 host fcoemon[1343]: error 111 Connection refused
ott 27 22:45:09 host fcoemon[1343]: Failed to connect to lldpad

Version-Release number of selected component (if applicable):
selinux-policy-targeted-3.13.1-128.16.fc22.noarch
Comment 1 Germano Massullo 2015-12-02 09:00:57 EST

*** This bug has been marked as a duplicate of bug 1268668 ***

Note You need to log in before you can comment on or make changes to this bug.