Bug 1275902 - Strange wording of developer workflow for "name"
Strange wording of developer workflow for "name"
Status: CLOSED CURRENTRELEASE
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Jessica Forrester
yapei
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-28 01:48 EDT by Erik M Jacobs
Modified: 2016-09-07 16:56 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-07 16:56:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Erik M Jacobs 2015-10-28 01:48:37 EDT
atomic-openshift-3.0.2.903-0.git.73.16a78c7.el7aos.x86_64
atomic-openshift-clients-3.0.2.903-0.git.73.16a78c7.el7aos.x86_64
atomic-openshift-master-3.0.2.903-0.git.73.16a78c7.el7aos.x86_64
atomic-openshift-node-3.0.2.903-0.git.73.16a78c7.el7aos.x86_64
atomic-openshift-sdn-ovs-3.0.2.903-0.git.73.16a78c7.el7aos.x86_64
tuned-profiles-atomic-openshift-node-3.0.2.903-0.git.73.16a78c7.el7aos.x86_64

When going through the web UI "add to project" workflow, the subtext under the "name" field is:

Used to uniquely identify within this project all the resources created to support the application.

This is a very strange passive construction. What do you think about:

"Used to uniquely identify all of the resources created to support this code in this project"

Or something to that effect.
Comment 1 Erik M Jacobs 2015-10-28 01:49:32 EDT
The page where this occurs:

https://ose3-master.example.com:8443/console/project/foo/create/fromimage?imageName=nodejs&imageTag=0.10&namespace=openshift

Looks like "/console/project/$PROJNAME/create/fromimage"
Comment 3 openshift-github-bot 2016-02-02 13:30:44 EST
Commit pushed to master at https://github.com/openshift/origin

https://github.com/openshift/origin/commit/fb2e7d065e331a51cc04f11c782eaa94c6639a8b
Bug 1275902 - fix help text for name field on create from image
Comment 4 yapei 2016-02-03 05:00:30 EST
will check when new OSE puddle is ready
Comment 5 yapei 2016-02-13 20:41:06 EST
checked on 2016-02-11 puddle, 
openshift v3.1.1.6-16-g5327e56
kubernetes v1.1.0-origin-1107-g4c8e6f4
etcd 2.1.2

fixed not merged yet
Comment 6 yapei 2016-02-17 03:51:25 EST
checked on puddle 3.2/2016-02-16.1

When create from image, help text for name field is "Identify the resources created for this application"

this sounds reasonable, move to verified

Note You need to log in before you can comment on or make changes to this bug.