Bug 127593 - Patch to add missing IGMPv3 support in headers
Patch to add missing IGMPv3 support in headers
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
http://sources.redhat.com/bugzilla/sh...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-09 21:16 EDT by Charles R. Anderson
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 04:48:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to add IGMPv3 support to glibc headers (4.38 KB, patch)
2004-07-09 21:18 EDT, Charles R. Anderson
no flags Details | Diff

  None (edit)
Description Charles R. Anderson 2004-07-09 21:16:40 EDT
Description of problem:

glibc doesn't support IGMPv3 (required for source-specific multicast).
For example, it lacks IP_ADD_SOURCE_MEMBERSHIP and
IP_DROP_SOURCE_MEMBERSHIP in it's headers.

P.S.: the support for IGMPv3 has been added in the GNU/Linux kernel
since versions 2.4.22 and 2.5.68.

Version-Release number of selected component (if applicable):
2.3.3-36

Additional info:

See sources.redhat.com bugzilla with older patch that applies cleanly
to glibc-2.2.5 through glibc-2.3.2-11.9 (Red Hat 9) and glibc-2.3.3-8
(earlier development):

http://sources.redhat.com/bugzilla/show_bug.cgi?id=5

I've updated the patch for latest development glibc-2.3.3-36.  Please
apply so IGMPv3 / SSM applications can be built.

Thanks.
Comment 1 Charles R. Anderson 2004-07-09 21:18:43 EDT
Created attachment 101776 [details]
Patch to add IGMPv3 support to glibc headers
Comment 2 Ulrich Drepper 2004-09-30 04:48:03 EDT
We have IGMPv3 support for some time in the rawhide glibc.  Test it
and if something is wrong/missing, file a new bug.

Note You need to log in before you can comment on or make changes to this bug.