This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1275945 - undefined method error on Red Hat Satellite provider refresh
undefined method error on Red Hat Satellite provider refresh
Status: CLOSED WORKSFORME
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers (Show other bugs)
5.5.0
Unspecified Unspecified
high Severity high
: GA
: 5.5.0
Assigned To: Brandon Dunne
Dave Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-28 03:23 EDT by Aziza Karol
Modified: 2015-11-12 08:49 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-12 08:49:39 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aziza Karol 2015-10-28 03:23:02 EDT
Description of problem:


Version-Release number of selected component (if applicable):
5.5.0.7

How reproducible:
100%

Steps to Reproduce:
1.Navigate to infrastructure->configuration mamagement
2.Add redhat satellite provider
3.wait for refresh or click on refresh relationships and power states

Actual results:
ERROR -- : [NoMethodError]: undefined method `key?' for nil:NilClass  Method:[rescue in block in refresh]

Expected results:


Additional info:
production.log
[----] I, [2015-10-28T03:12:59.167846 #27711:1137990]  INFO -- : MIQ(ManageIQ::Providers::Foreman::Provider#with_provider_connection) Connecting through ManageIQ::Providers::Foreman::Provider: [sat6]
[----] I, [2015-10-28T03:12:59.170225 #27711:1137990]  INFO -- : ManageiqForeman::Connection#fetch Calling Apipie Resource: :hosts Action: :index Params: {:page=>1, :per_page=>50, "root_pass"=>"<FILTERED>"}
[----] I, [2015-10-28T03:12:59.350716 #2684:1289988]  INFO -- : MIQ(MiqServer#heartbeat) Heartbeat [2015-10-28 07:12:59 UTC]...
[----] I, [2015-10-28T03:12:59.364844 #2684:1289988]  INFO -- : MIQ(MiqServer#heartbeat) Heartbeat [2015-10-28 07:12:59 UTC]...Complete
[----] I, [2015-10-28T03:12:59.380131 #2684:1289988]  INFO -- : MIQ(MiqServer#populate_queue_messages) Fetched 1 miq_queue rows for queue_name=ems_2, wcount=1, priority=200
[----] I, [2015-10-28T03:12:59.380119 #27711:1137990]  INFO -- : ManageiqForeman::Connection#fetch Calling Apipie Resource: :hostgroups Action: :index Params: {:page=>1, :per_page=>50, "root_pass"=>"<FILTERED>"}
[----] E, [2015-10-28T03:12:59.524531 #27711:1137990] ERROR -- : MIQ(ManageIQ::Providers::Foreman::ConfigurationManager::Refresher#refresh) EMS: [sat6 Configuration Manager], id: [1] Refresh failed
[----] E, [2015-10-28T03:12:59.524797 #27711:1137990] ERROR -- : [NoMethodError]: undefined method `key?' for nil:NilClass  Method:[rescue in block in refresh]
[----] E, [2015-10-28T03:12:59.524896 #27711:1137990] ERROR -- : /var/www/miq/vmdb/gems/manageiq_foreman/lib/manageiq_foreman/inventory.rb:16:in `refresh_configuration'
/var/www/miq/vmdb/app/models/manageiq/providers/foreman/configuration_manager/refresher.rb:8:in `block in parse_inventory'
/var/www/miq/vmdb/app/models/provider.rb:46:in `with_provider_connection'
/var/www/miq/vmdb/app/models/manageiq/providers/foreman/configuration_manager.rb:11:in `with_provider_connection'
/var/www/miq/vmdb/app/models/manageiq/providers/foreman/configuration_manager/refresher.rb:7:in `parse_inventory'
/var/www/miq/vmdb/app/models/ems_refresh/refreshers/ems_refresher_mixin.rb:19:in `block in refresh'
/var/www/miq/vmdb/app/models/ems_refresh/refreshers/ems_refresher_mixin.rb:7:in `each'
/var/www/miq/vmdb/app/models/ems_refresh/refreshers/ems_refresher_mixin.rb:7:in `refresh'
/var/www/miq/vmdb/app/models/manageiq/providers/base_manager/refresher.rb:10:in `refresh'
/var/www/miq/vmdb/app/models/ems_refresh.rb:76:in `block in refresh'
/var/www/miq/vmdb/app/models/ems_refresh.rb:75:in `each'
/var/www/miq/vmdb/app/models/ems_refresh.rb:75:in `refresh'
/var/www/miq/vmdb/app/models/miq_queue.rb:345:in `block in deliver'
/opt/rh/rh-ruby22/root/usr/share/ruby/timeout.rb:89:in `block in timeout'
/opt/rh/rh-ruby22/root/usr/share/ruby/timeout.rb:34:in `block in catch'
/opt/rh/rh-ruby22/root/usr/share/ruby/timeout.rb:34:in `catch'
/opt/rh/rh-ruby22/root/usr/share/ruby/timeout.rb:34:in `catch'
/opt/rh/rh-ruby22/root/usr/share/ruby/timeout.rb:104:in `timeout'
/var/www/miq/vmdb/app/models/miq_queue.rb:341:in `deliver'
/var/www/miq/vmdb/app/models/miq_queue_worker_base/runner.rb:106:in `deliver_queue_message'
/var/www/miq/vmdb/app/models/miq_queue_worker_base/runner.rb:134:in `deliver_message'
/var/www/miq/vmdb/app/models/miq_queue_worker_base/runner.rb:151:in `block in do_work'
/var/www/miq/vmdb/app/models/miq_queue_worker_base/runner.rb:145:in `loop'
/var/www/miq/vmdb/app/models/miq_queue_worker_base/runner.rb:145:in `do_work'
/var/www/miq/vmdb/app/models/miq_worker/runner.rb:323:in `block in do_work_loop'
/var/www/miq/vmdb/app/models/miq_worker/runner.rb:320:in `loop'
/var/www/miq/vmdb/app/models/miq_worker/runner.rb:320:in `do_work_loop'
/var/www/miq/vmdb/app/models/miq_worker/runner.rb:142:in `run'
/var/www/miq/vmdb/app/models/miq_worker/runner.rb:123:in `start'
/var/www/miq/vmdb/app/models/miq_worker/runner.rb:24:in `start_worker'
/var/www/miq/vmdb/lib/workers/bin/worker.rb:2:in `<top (required)>'
/opt/rh/cfme-gemset/gems/railties-4.2.4/lib/rails/commands/runner.rb:60:in `load'
/opt/rh/cfme-gemset/gems/railties-4.2.4/lib/rails/commands/runner.rb:60:in `<top (required)>'
/opt/rh/cfme-gemset/gems/railties-4.2.4/lib/rails/commands/commands_tasks.rb:123:in `require'
/opt/rh/cfme-gemset/gems/railties-4.2.4/lib/rails/commands/commands_tasks.rb:123:in `require_command!'
/opt/rh/cfme-gemset/gems/railties-4.2.4/lib/rails/commands/commands_tasks.rb:90:in `runner'
/opt/rh/cfme-gemset/gems/railties-4.2.4/lib/rails/commands/commands_tasks.rb:39:in `run_command!'
/opt/rh/cfme-gemset/gems/railties-4.2.4/lib/rails/commands.rb:17:in `<top (required)>'
/var/www/miq/vmdb/bin/rails:4:in `require'
/var/www/miq/vmdb/bin/rails:4:in `<main>'
[----] E, [2015-10-28T03:12:59.524984 #27711:1137990] ERROR -- : MIQ(ManageIQ::Providers::Foreman::ConfigurationManager::Refresher#refresh) EMS: [sat6 Configuration Manager], id: [1] Unable to perform refresh for the following targets:
[----] E, [2015-10-28T03:12:59.525110 #27711:1137990] ERROR -- : MIQ(ManageIQ::Providers::Foreman::ConfigurationManager::Refresher#refresh)  --- ManageIQ::Providers::Foreman::ConfigurationManager [sat6 Configuration Manager] id [1]
[----] I, [2015-10-28T03:12:59.547776 #27711:1137990]  INFO -- : MIQ(ManageIQ::Providers::Foreman::ConfigurationManager::Refresher#refresh) Refreshing all targets...Complete
Comment 2 Greg Blomquist 2015-10-29 10:16:54 EDT
Brandon, can you take a look at this?
Comment 3 Brandon Dunne 2015-11-09 10:25:52 EST
I am not able to reproduce this error.  Can you provide more steps to reproduce?  Does this need to be a specific version or have a specific configuration?
Comment 4 Aziza Karol 2015-11-12 08:49:39 EST
This issue is not reproducible in version 5.5.0.10-beta2.1.20151110134042_d6f5459

Note You need to log in before you can comment on or make changes to this bug.