Bug 1275977 - Guest mouse doesn't work after hotplug memory and reboot
Guest mouse doesn't work after hotplug memory and reboot
Status: CLOSED DUPLICATE of bug 1271527
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev (Show other bugs)
7.2
x86_64 Linux
unspecified Severity medium
: rc
: ---
Assigned To: Igor Mammedov
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-28 05:26 EDT by Yumei Huang
Modified: 2016-01-20 05:36 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-20 05:36:35 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
full dmesg of hotplug memory (140.26 KB, text/plain)
2015-10-28 05:29 EDT, Yumei Huang
no flags Details
full dmesg after reboot (94.65 KB, text/plain)
2015-10-28 05:32 EDT, Yumei Huang
no flags Details

  None (edit)
Description Yumei Huang 2015-10-28 05:26:31 EDT
Description of problem:
Hotplug memory to guest 256 times , then reboot the guest, the guest mouse doesn't work.

Version-Release number of selected component (if applicable):
kernel: 3.10.0-326.el7.x86_64
qemu-kvm-rhev-2.3.0-31.el7.x86_64

How reproducible:
always

Steps to Reproduce:
1. launch a guest with cmd:
/usr/libexec/qemu-kvm -name rhel72-sn5 -m 1G,slots=256,maxmem=40G \

-numa node -smp 4,sockets=4,cores=1,threads=1 \

-no-user-config -nodefaults -rtc base=utc,driftfix=slew -global kvm-pit.lost_tick_policy=discard -boot menu=on,strict=on \

-object iothread,id=iothread0 -drive file=/home/guest/rhel72-sn5.img,if=none,id=drive-data-disk,format=qcow2,cache=none,aio=native,werror=stop,rerror=stop  -device virtio-blk-pci,drive=drive-data-disk,id=data-disk,iothread=iothread0,bus=pci.0,addr=0x7 \

-netdev tap,id=hostnet1,vhost=on -device e1000,netdev=hostnet1,id=net2,mac=10:1a:4a:42:0a:0b,bus=pci.0,addr=0xa \

-usb -device usb-tablet,id=input0 -vga qxl \

-spice port=5901,addr=0.0.0.0,disable-ticketing,image-compression=off,seamless-migration=on -monitor unix:/tmp/monitor3,server,nowait

2. Hotplug 128M memory to guest 256 times with script:
#!/bin/bash 
i=0 
while [ $i -lt 256 ] 
do 
echo $i 
sleep 3 
echo "object_add memory-backend-ram,id=mem$i,size=128M"|nc -U /tmp/monitor3 
sleep 2 
echo "device_add pc-dimm,id=dimm$i,memdev=mem$i,slot=$i"|nc -U /tmp/monitor3 
i=$(($i+1)) 
done 

3. Reboot the guest. 

Actual results:
No mouse cursor. Mouse doesn't work inside guest.

Expected results:
Guest mouse works well.

Additional info:
Comment 1 Yumei Huang 2015-10-28 05:29 EDT
Created attachment 1087177 [details]
full dmesg of hotplug memory
Comment 2 Yumei Huang 2015-10-28 05:32 EDT
Created attachment 1087178 [details]
full dmesg after reboot
Comment 4 Igor Mammedov 2016-01-20 05:36:35 EST

*** This bug has been marked as a duplicate of bug 1271527 ***

Note You need to log in before you can comment on or make changes to this bug.