Bug 1276003 - Can not download log by clicking "Raw" link on Firefox41/IE11/Safari9
Can not download log by clicking "Raw" link on Firefox41/IE11/Safari9
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Management Console (Show other bugs)
3.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: bpeterse
yapei
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-28 07:03 EDT by Yanping Zhang
Modified: 2015-11-23 16:15 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-23 16:15:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yanping Zhang 2015-10-28 07:03:45 EDT
Description of problem:
After view the log of builds/pods under the Log label directly, try to download the log by click the "Raw" link, it has no response on Firefox41/IE11, and on safari9, it display the logs on the browser directly instead of downloading it.
The log can be downloaded on Chrome47.

Version-Release number of selected component (if applicable):
openshift v1.0.6-997-gff3b522
kubernetes v1.2.0-alpha.1-1107-g4c8e6f4
etcd 2.1.2


How reproducible:
Always

Steps to Reproduce:
1.Create app in project.
$oc create -f origin/examples/sample-app/application-template-stibuild.json
$oc new-app ruby-helloworld-sample
2.Check the build/pods log on web console on Chrome47/Firefox41/IE11/Safari9, and try to download the log by clicking the "Raw" link.
3.

Actual results:
2.Failed to download logs on Firefox41/IE11/Safari9

Expected results:
3.Should download successfully.

Additional info:
Comment 1 Yanping Zhang 2015-10-29 02:11:24 EDT
Tested on latest origin code again:
openshift v1.0.6-1053-gbd6a762
kubernetes v1.2.0-alpha.1-1107-g4c8e6f4
etcd 2.1.2

Now could download log from Chrome47/Firefox41, still can not download from IE11/Safari9.
On IE11, there is no response when click "Raw" link.
On safari, it displays the log context on the browser directly when click "Raw" link.
Comment 2 bpeterse 2015-10-29 15:46:42 EDT
 Yanping, at this time it sounds like we may be removing the download functionality.  It may return in a later release.
Comment 3 Samuel Padgett 2015-10-30 13:14:35 EDT
We've removed the link because it doesn't work in all browsers.

https://github.com/openshift/origin/pull/5537
Comment 4 Yanping Zhang 2015-11-01 22:11:03 EST
Checked on devenv-rhel7_2619。
openshift v1.0.7-109-g3cf7f3c
kubernetes v1.2.0-alpha.1-1107-g4c8e6f4
etcd 2.1.2

Since the link has been removed, the issue doesn't exist now, so move the bug to Verified.

Note You need to log in before you can comment on or make changes to this bug.