Bug 1276004 - Can not get log context under Log label on iphone/ipad
Can not get log context under Log label on iphone/ipad
Product: OpenShift Origin
Classification: Red Hat
Component: Management Console (Show other bugs)
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: bpeterse
Depends On:
  Show dependency treegraph
Reported: 2015-10-28 07:03 EDT by Yanping Zhang
Modified: 2015-10-29 09:46 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2015-10-29 09:46:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Chrome iPhone 5 emulator view of build/logs (68.94 KB, image/png)
2015-10-28 16:33 EDT, bpeterse
no flags Details
log-ipad (67.66 KB, image/png)
2015-10-29 00:10 EDT, Yanping Zhang
no flags Details
log-iphone (818.34 KB, image/png)
2015-10-29 00:11 EDT, Yanping Zhang
no flags Details

  None (edit)
Description Yanping Zhang 2015-10-28 07:03:59 EDT
Description of problem:
After created app in project, try to view the builds/pods log under Log label from web console on iphone/ipad, the log contexts are not displayed in the box.

Version-Release number of selected component (if applicable):
openshift v1.0.6-997-gff3b522
kubernetes v1.2.0-alpha.1-1107-g4c8e6f4
etcd 2.1.2

How reproducible:

Steps to Reproduce:
1.Create app in project.
$oc create -f origin/examples/sample-app/application-template-stibuild.json
$oc new-app ruby-helloworld-sample
2. View the builds/pods log under Log label from web console on iphone/ipad

Actual results:
2.The log contexts are not displayed in the box

Expected results:
3.Should show log contexts correctly in the box.

Additional info:
Comment 1 bpeterse 2015-10-28 15:43:02 EDT
Yanping, would you mind posting a screenshot?  I want to make sure I understand your issue completely. I'm looking at this bug today via an iPhone emulator.  Thanks!
Comment 2 bpeterse 2015-10-28 16:33 EDT
Created attachment 1087322 [details]
Chrome iPhone 5 emulator view of build/logs
Comment 3 bpeterse 2015-10-28 16:34:16 EDT
I just added a screenshot of what I see via iPhone emulator.  I did make some minor layout changes here to improve readability, they will be going in with a PR from Steve Goodwin in the near future.
Comment 4 Yanping Zhang 2015-10-29 00:10 EDT
Created attachment 1087364 [details]
Comment 5 Yanping Zhang 2015-10-29 00:11 EDT
Created attachment 1087365 [details]
Comment 6 Yanping Zhang 2015-10-29 00:27:24 EDT
Posted the screenshot for ipad/iphone simulator, pls check the attachments, thanks!
Comment 7 Jessica Forrester 2015-10-29 09:46:47 EDT
This is the same problem as the terminal:

This is the known issue with websockets in safari/iOS when the self-signed cert has not been installed.

You can install a cert on iOS by putting the cert file at some location you can hit within the browser.  When iOS safari goes to download it, it will ask you if you want to Install the cert as a profile in the iOS Settings.

The cert you want is the openshift.local.config/master/ca.crt

Once I did this I was able to use the logs on iOS

Note You need to log in before you can comment on or make changes to this bug.