Bug 1276119 - lucene is FTBFS in rawhide since xmvn update to 2.5.0
lucene is FTBFS in rawhide since xmvn update to 2.5.0
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xmvn (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Mikolaj Izdebski
Fedora Extras Quality Assurance
https://apps.fedoraproject.org/kosche...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-28 14:56 EDT by Mat Booth
Modified: 2015-10-29 06:09 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-29 06:09:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mat Booth 2015-10-28 14:56:15 EDT
Description of problem:
Package lucene fails to build from source in rawhide since xmvn was updated to 2.5.0

FWIW, lucene uses ivy, here's a log snippet:

[ivy:retrieve] :: Apache Ivy 2.4.0-local-20150617001712 - 20150617001712 :: http://ant.apache.org/ivy/ ::
[ivy:retrieve] :: loading settings :: file = /etc/ivy/ivysettings.xml
BUILD FAILED
/builddir/build/BUILD/lucene-5.3.1/lucene/common-build.xml:806: The following error occurred while executing this line:
/builddir/build/BUILD/lucene-5.3.1/lucene/common-build.xml:430: java.lang.NoClassDefFoundError: org/eclipse/sisu/space/ClassSpace

Version-Release number of selected component (if applicable):
5.3.1-1.fc24

Steps to Reproduce:
koji build --scratch f24 lucene-5.3.1-1.fc24.src.rpm

Additional info:
This package is tracked by Koschei. See:
https://apps.fedoraproject.org/koschei/package/lucene
Comment 1 Mat Booth 2015-10-29 06:09:40 EDT
Aha, looks like this is fixed with xmvn 2.5.0-2

Note You need to log in before you can comment on or make changes to this bug.