Bug 1276121 - [Docs][Install][3.5] Wrong syntax for automated VLAN assignment on Red Hat Enterprise Virtualization Hypervisor
[Docs][Install][3.5] Wrong syntax for automated VLAN assignment on Red Hat En...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: Documentation (Show other bugs)
3.5.0
Unspecified Unspecified
unspecified Severity medium
: ovirt-3.5.6
: ---
Assigned To: Julie
rhev-docs@redhat.com
docs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-28 14:57 EDT by Chris Reynolds
Modified: 2016-02-10 13:57 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-22 20:19:01 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Docs
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Reynolds 2015-10-28 14:57:34 EDT
Description of problem:
The docs at https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Virtualization/3.5/html/Installation_Guide/sect-Automated_Installation.html use the wrong vlan syntax.

Current docs
----
vlan
    The vlan parameter sets the VLAN identifier for the network connected to the Red Hat Enterprise Virtualization Manager. This parameter should be set where VLANs are in use.

Example =>  vlan=vlan-id
----

However this fails with the same error seen in this solution https://access.redhat.com/solutions/500843

Error Seen
----
dracut: FATAL: vlan= requires two parameters
dracut: Refusing to continue
-----

Our doc should show the correct syntax as seen in this solution above
----
vlan=<vlanid>:<interface>
(eg: vlan=eth0.36:eth0)

Version-Release number of selected component (if applicable):
3.5

How reproducible:
easy

Steps to Reproduce:
1. follow documentation
2.
3.

Actual results:
dracut: FATAL: vlan= requires two parameters
dracut: Refusing to continue

Expected results:
no error

Additional info:
Comment 1 Julie 2015-11-17 20:54:29 EST
Hi Chris,
  Thanks for filing this bug. The issue you reported has been fixed in:
https://bugzilla.redhat.com/show_bug.cgi?id=1281399
and will be published shortly with the 3.6 Beta release. 
I will make sure the change is backported to the 3.5 Install Guide as well. 

Please let me know if you have further feedback.

Cheers,
Julie
Comment 3 Chris Reynolds 2015-11-24 12:29:04 EST
Awesome! Thanks Julie!
Comment 4 Eyal Edri 2015-11-29 07:23:15 EST
should this be targeted to 3.5.6 rather than 3.5.7?
since 3.5.6 is due to be released this week.
Comment 5 Andrew Dahms 2015-11-29 18:27:39 EST
Hi Eyal,

Thank you for asking after this bug.

This content will indeed be released with the updates to the documentation that are planned for RHEV 3.5.6, and we will move it to CLOSED - CURRENT RELEASE after the content has been published.

Let us know at any time if you have any further questions or concerns.

Kind regards,

Andrew

Note You need to log in before you can comment on or make changes to this bug.