Bug 1276152 - Bug or RFE? Error when resizing lvm volumes for docker
Bug or RFE? Error when resizing lvm volumes for docker
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: system-storage-manager (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Lukáš Czerner
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-28 17:47 EDT by Langdon White
Modified: 2016-03-17 08:55 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-17 08:55:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Langdon White 2015-10-28 17:47:24 EDT
Description of problem:
I configured the docker storage based on http://www.projectatomic.io/blog/2015/06/notes-on-fedora-centos-and-docker-storage-drivers/ , mostly. I created the two logical volumes by hand per the recommendation (not using docker-storage-setup). Today, I had to make the "docker_data" volume bigger. When I attempted to use "ssm resize -s 10G /dev/mapper/fedora/docker_data" I got the following:

udo ssm resize -s 10G /dev/fedora/docker_data
fsck from util-linux 2.27
/dev/mapper/fedora-docker_data: The filesystem size (according to the superblock) is 26214400 blocks
The physical size of the device is 1310720 blocks
Either the superblock or the partition table is likely to be corrupt!


/dev/mapper/fedora-docker_data: UNEXPECTED INCONSISTENCY; RUN fsck MANUALLY.
	(i.e., without -a or -p options)
  Filesystem check failed.
SSM Error (2012): ERROR running command: "lvm lvresize -r -L 10485760.0k /dev/fedora/docker_data"

however, "lvextend -L 10G /dev/fedora/docker_data" worked fine. 

If the right answer would have been to do "ssm resize -s +5G /dev/mapper/fedora/docker_data" well, I am not sure if it is my bash-fu but I can never get it to "like" the "+". 

Version-Release number of selected component (if applicable):
Version     : 0.4
Release     : 8.fc23
Comment 1 Lukáš Czerner 2015-10-30 05:33:59 EDT
I am not sure what was the intention ? Was it to make the volume 10GB in size, or to make it 5GB bigger ?

Also note that lvresize without (-r) works because it does not try to resize the file system. In your ssm case it tries to resize the file system but it found a problem because the volume is smaller than the file system itself which might be caused by shrinking the volume using lvresize without shrinking the file system first.

When resizing volume with the file system ssm needs to make sure that the file system is not corrupted otherwise we might cause even more problems by resizing it.

-Lukas
Comment 2 Lukáš Czerner 2016-03-17 08:55:44 EDT
This is not a problem of ssm, but it looks like a bad setup or administrator error so I am going to close this one.

-Lukas

Note You need to log in before you can comment on or make changes to this bug.