Bug 127623 - Add ID3V2 support in grip
Add ID3V2 support in grip
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: grip (Show other bugs)
2
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-11 08:10 EDT by Shantanu Goel
Modified: 2014-03-16 22:46 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-04 18:08:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shantanu Goel 2004-07-11 08:10:09 EDT
Description of problem:
The grip shipped with FC2 lacks support for ID3V2 which is a nuisance
since ID3V1 has a very limited range for title/album/artist fields.

Version-Release number of selected component (if applicable):
3.0.7-4

How reproducible:
Always

Steps to Reproduce:
1. Try ripping a CD where any of the above mentioned fields exceed 30
characters.
2.
3.
  
Actual results:
The fields will be truncated in the resulting OGG file.

Expected results:
With ID3V2 the limits are increased so the likelyhood of truncation is
much less.

Additional info:
Comment 1 Bill Nottingham 2004-07-12 17:03:30 EDT
Is this implemented in upstream grip at all?
Comment 2 Shantanu Goel 2004-07-12 18:48:44 EDT
I believe so since I'm using grip-3.2.0-1.1.fc2.dag from DAG RPMs
which supports ID3V2.  It does, however, require id3lib which DAG
provides but isn't included in base FC2.  If id3lib is installed, the
grip configure script automatically picks it up and uses it to provide
ID3V2 support.

Comment 3 Matthias Saou 2004-07-22 15:01:54 EDT
OTOH, id3lib seems like a really ugly lib once you get your nose in
the code (unlike libid3tag, which seems nicer), so I wouldn't blame
Red Hat for not wanting to ship it. Maybe someone could convince
grip's author to switch libraries?
Comment 4 Bill Nottingham 2005-02-04 18:08:54 EST
grip is no longer shipped in the development tree; as such, it is unlikely older
bugs will be fixed.

Note You need to log in before you can comment on or make changes to this bug.