Bug 1276238 - [devexp_public_681]Debug and error appeas when use oc rsync command to sync file using 'rsync-daemon' strategy
[devexp_public_681]Debug and error appeas when use oc rsync command to sync f...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
3.x
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Cesar Wong
Xingxing Xia
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-29 04:25 EDT by Wang Haoran
Modified: 2016-12-09 16:50 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-12-09 16:50:01 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wang Haoran 2015-10-29 04:25:57 EDT
Description of problem:

With rsync install on local and container, when sync file using oc rsync command daemon strategy will print debug log in console.
Version-Release number of selected component (if applicable):

openshift v1.0.6-1073-g5238357
kubernetes v1.2.0-alpha.1-1107-g4c8e6f4
oc v1.0.6-1073-g5238357
AMI:devenv-rhel7_2589
How reproducible:
always

Steps to Reproduce:
1.create a project
2.new app
 $oc new-app openshift3/ruby-20-rhel7~https://github.com/openshift/ruby-hello-world.git
3.sync files to an existed directory on pod after the deploy success
$oc rsync /tmp/test/ ruby-hello-world-1-7y7lj:/tmp/test/ --strategy='rsync-daemon'

Actual results:
[root@ip-172-18-9-210 tmp]# oc rsync /tmp/test/ ruby-hello-world-1-7y7lj:/tmp/test/ --strategy='rsync-daemon'
I1029 04:02:41.198554    6469 portforward.go:212] Forwarding from 127.0.0.1:33998 -> 34673
I1029 04:02:41.198703    6469 portforward.go:212] Forwarding from [::1]:33998 -> 34673
I1029 04:02:41.200657    6469 portforward.go:246] Handling connection for 33998
sending incremental file list

sent 39 bytes  received 8 bytes  94.00 bytes/sec
total size is 0  speedup is 0.00
[root@ip-172-18-9-210 tmp]# oc rsync /tmp/test/ ruby-hello-world-1-7y7lj:/tmp/ --strategy='rsync-daemon'
I1029 04:04:16.593410    6535 portforward.go:212] Forwarding from 127.0.0.1:50911 -> 47406
I1029 04:04:16.593519    6535 portforward.go:212] Forwarding from [::1]:50911 -> 47406
I1029 04:04:16.594850    6535 portforward.go:246] Handling connection for 50911
sending incremental file list
./
rsync: failed to set permissions on "/tmp/." (in root): Operation not permitted (1)
testfile

sent 81 bytes  received 30 bytes  222.00 bytes/sec
total size is 0  speedup is 0.00
rsync error: some files/attrs were not transferred (see previous errors) (code 23) at main.c(1052) [sender=3.0.9]
error: exit status 23


Expected results:
should successfully sync the file without debug log output.

Additional info:
Comment 1 Cesar Wong 2016-09-29 23:12:15 EDT
Fixed since kube rebase on https://github.com/openshift/origin/pull/8856. Should be included in v1.3.0 of origin.
Comment 2 Wang Haoran 2016-09-30 04:51:48 EDT
Verified with :
[root@ip-172-18-0-34 test]# openshift version
openshift v1.4.0-alpha.0+75ee6c9
kubernetes v1.4.0-beta.3+d19513f
etcd 3.1.0-alpha.1

oc rsync /tmp/test/ ruby-hello-world-1-dltcj:/tmp/test/ --strategy='rsync-daemon'
Forwarding from 127.0.0.1:44427 -> 59396
Forwarding from [::1]:44427 -> 59396
Handling connection for 44427
sending incremental file list

sent 43 bytes  received 8 bytes  34.00 bytes/sec
total size is 0  speedup is 0.00

Note You need to log in before you can comment on or make changes to this bug.