Bug 1276259 - Appears permission error when accessing mongodb26
Appears permission error when accessing mongodb26
Status: CLOSED WORKSFORME
Product: Red Hat Software Collections
Classification: Red Hat
Component: rh-mongodb26-docker (Show other bugs)
devassist09
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Marek Skalický
Wenjing Zheng
: Regression, Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-29 05:35 EDT by wewang
Modified: 2015-12-10 07:15 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-10 07:15:12 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
wewang: needinfo-


Attachments (Terms of Use)

  None (edit)
Description wewang 2015-10-29 05:35:49 EDT
Version-Release number of selected component (if applicable):
rhscl/mongodb-26-rhel7       fead03cf7fc4
Description of problem:
when login in mongodb26 in container,appears error "open for '//.mongorc.js' failed with errno:13 Permission denied"

How reproducible:
Always


Steps to Reproduce:
1.Create project
2. Create mongodb26 imagestream
3. oc new-app -f mongodb-ephemeral-template.json
# oc get pods
NAME               READY     STATUS        RESTARTS   AGE
mongodb-1-9ncyn    1/1       Running       0          33s
mongodb-1-deploy   0/1       Terminating   0          36s

4. Access into container
# oc env pod mongodb-1-9ncyn --list
# pods mongodb-1-9ncyn, container mongodb
MONGODB_USER=userQYW
MONGODB_PASSWORD=wXCewlVGM1vylgu1
MONGODB_DATABASE=sampledb
MONGODB_ADMIN_PASSWORD=rRGgyDBUOVUstiOm
[root@dhcp-128-91 v3test]# oc rsh mongodb-1-9ncyn
bash-4.2$ mongo sampledb -u userQYW -pwXCewlVGM1vylgu1
MongoDB shell version: 2.6.9
connecting to: sampledb
Welcome to the MongoDB shell.
For interactive help, type "help".
For more comprehensive documentation, see
    http://docs.mongodb.org/
Questions? Try the support group
    http://groups.google.com/group/mongodb-user
2015-10-29T02:10:20.022-0400 In File::open(), ::open for '//.mongorc.js' failed with errno:13 Permission denied
> 


Actual results:
when Login in mongodb26, appear errors


Expected results:
login in successfully ,no errors

Additional:
doing follow , has the same problem:
$mkdir -p /home/user/database &&  chown -R 234523:998 /home/user/database
$  docker run -d -u 234523 -e MONGODB_USER=user -e MONGODB_PASSWORD=pass -e MONGODB_DATABASE=test_db -e MONGODB_ADMIN_PASSWORD=pass -v /home/user/database:/var/lib/mongodb/data:Z  rhscl/mongodb-26-rhel7

2.Access into container
$docker ps | grep mongo  (to get the container id)
$docker inspect <container_id> | grep IPAddress
$docker exec -ti <container_id> scl enable rh-mongodb26 /bin/bash

3. Create SQL queries in container 
bash-4.2$ mongo test_db -u user -p pass 
MongoDB shell version: 2.6.9
connecting to: test_db
Welcome to the MongoDB shell.
For interactive help, type "help".
For more comprehensive documentation, see
    http://docs.mongodb.org/
Questions? Try the support group
    http://groups.google.com/group/mongodb-user
2015-09-24T03:17:01.840+0000 In File::open(), ::open for '//.mongorc.js' failed with errno:13 Permission denied
>
Comment 4 Marek Skalický 2015-11-02 07:50:15 EST
Feel free to reopen.

*** This bug has been marked as a duplicate of bug 1273842 ***
Comment 15 Wang Haoran 2015-12-06 20:58:52 EST
Marek, I cannot reprocude it, see my comment https://bugzilla.redhat.com/show_bug.cgi?id=1276259#c9, the bug is gone, feel free to move the status to on_qa.
Comment 16 Marek Skalický 2015-12-10 07:15:12 EST
Since this bug is not reproducible and there weren't any changes/patches to fix this bug. I am closing it.

Feel free to reopen.

Note You need to log in before you can comment on or make changes to this bug.