Bug 1276378 - [RFE] Removing Nodes with Heat Templates results in stale entries in "nova-manage service list"
[RFE] Removing Nodes with Heat Templates results in stale entries in "nova-ma...
Status: CLOSED DUPLICATE of bug 1404844
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
low Severity medium
: ---
: 11.0 (Ocata)
Assigned To: Hugh Brock
Amit Ugol
: FutureFeature, Unconfirmed
: 1276065 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-29 10:50 EDT by Jeremy
Modified: 2017-01-04 11:58 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-01-04 11:58:11 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeremy 2015-10-29 10:50:57 EDT
Description of problem:
Removing Nodes with Heat Templates results in stale entries in "nova-manage service list"

#nova-manage service list
Result:- 
Binary           Host                                 Zone             Status     State Updated_At
nova-scheduler   overcloud-controller-0.localdomain   internal         enabled    :-)   2015-10-28 13:37:35
nova-consoleauth overcloud-controller-0.localdomain   internal         enabled    :-)   2015-10-28 13:37:41
nova-conductor   overcloud-controller-0.localdomain   internal         enabled    :-)   2015-10-28 13:37:37
nova-compute     overcloud-compute-0.localdomain      nova             enabled    XXX   2015-10-28 13:29:24
nova-compute     overcloud-compute-1.localdomain      nova             enabled    XXX   2015-10-28 12:39:58

However you can use # nova service-delete [service-id] to delete the services.
Is possible to add functionality to delete the service when running the following command.

openstack overcloud node delete --stack [STACK] --templates ~/my-overcloud -e [ENVIRONMENT_FILE] [NODE1_UUID] [NODE2_UUID] [NODE3_UUID]

The directions are a little confusing because you issue the overcloud delete in section 7.7 https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux_OpenStack_Platform/7/html/Director_Installation_and_Usage/sect-Removing_Nodes_from_the_Overcloud.html and have to delete the service in section 7.2 https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux_OpenStack_Platform/7/html/Director_Installation_and_Usage/sect-Migrating_VMs_from_an_Overcloud_Compute_Node.html.
 
Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 chris alfonso 2015-11-11 12:48:47 EST
*** Bug 1276065 has been marked as a duplicate of this bug. ***
Comment 4 Mike Burns 2016-04-07 16:54:03 EDT
This bug did not make the OSP 8.0 release.  It is being deferred to OSP 10.
Comment 5 Jaromir Coufal 2017-01-04 11:58:11 EST

*** This bug has been marked as a duplicate of bug 1404844 ***

Note You need to log in before you can comment on or make changes to this bug.