Bug 127640 - tty locks up, made by init on exiting session, when using charset pt-latin1, terminal linux, and \w on PS1.
tty locks up, made by init on exiting session, when using charset pt-latin1, ...
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: mingetty (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Florian La Roche
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-11 20:17 EDT by Alexandre Costa
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-12 05:15:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexandre Costa 2004-07-11 20:17:11 EDT
Description of problem:
The problem appeared when using TERM=linux, charset pt-latin1, and 
putting \w on PS1 and moving to the homedir , on which case my prompt 
would display a "~" on it. On exiting a session, or even after 
exiting , pressing CTRL-D (sometimes just once , sometimes a few 
times), it made a message that is something like 'INIT : id "1" 
respawning too fast : disabled for 5 minutes' appear.. the tty1 is 
lost, and never recovered, not even a init 1 and afterwards a init 
3/5..  the only way to recover the lost tty was to reboot.. this also 
happens in simultaneous tty's.. once i had tty1 to 3 lost. 

Version-Release number of selected component (if applicable):
2.85-4

How reproducible:
every time

Steps to Reproduce:
1.using a linux terminal on a tty, with a pt-latin1 charset
2.export PS1='\w'
3.cd to a home dir, and check if the "~" char appears on the prompt
4. exit, by pressing a few times CTRL-d .
  
Actual results:
something like 'INIT : id "1" respawning too fast : disabled for 5 
minutes'

Expected results:
init should respawn a mingetty to that tty.

Additional info:
I think the problem its about init and something that happens on the 
terminal before, but i might be wrong .. i never had this problems 
using a english/american charset, and on other distros , this doesn't 
happen.
One thing which i think triggers the problem, is that in pt-latin1 
charset, the "~" is a deadkey ("ã"), and that the problem only really 
happens, when i move to a home and the prompt shows the "~" char on 
it. it can even be something wrong about the bash, or the mingetty 
for all i know.
Comment 1 Bill Nottingham 2004-07-12 17:33:36 EDT
I couldn't reproduce this in brief testing here.
Comment 2 Alexandre Costa 2004-07-12 18:34:03 EDT
I'll reproduce it , and send a step by step with output still this 
week.
Comment 3 Florian La Roche 2004-07-13 05:07:41 EDT
If you exit too often, the tty is disabled for some time. This is
a policy decision by /sbin/init.

Would be strange to loose a tty completely. Resetting the tty from
another tty might help sometimes.
Comment 4 Alexandre Costa 2004-07-13 20:32:10 EDT
The problem is that it isn't suposed to do that by sometimes just 
type "exit" on the shell. I wasn't able to replicate the bug today, 
but it happens often in a certain lab on the rh033 course (it might 
also be "lazy hand" of the students). I'll try to do the lab and test 
that a few times this week.. and try to reset the tty from another 
tty. If everything checks ok, shall I put this bug as NOTABUG ?
Comment 5 Alexandre Costa 2004-07-13 20:40:44 EDT
The problem is that it isn't suposed to do that by sometimes just 
type "exit" on the shell. I wasn't able to replicate the bug today, 
but it happens often in a certain lab on the rh033 course (it might 
also be "lazy hand" of the students). I'll try to do the lab and test 
that a few times this week.. and try to reset the tty from another 
tty. If everything checks ok, shall I put this bug as NOTABUG ?




Note You need to log in before you can comment on or make changes to this bug.