This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1276466 - SELinux is preventing gvfsd-fuse from 'mounton' accesses on the directory /run/user/1000/gvfs.
SELinux is preventing gvfsd-fuse from 'mounton' accesses on the directory /ru...
Status: CLOSED DUPLICATE of bug 1276462
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:c85a6c995feca1e81d2ad0f179a...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-29 15:03 EDT by Joachim Frieben
Modified: 2016-01-22 08:35 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-22 08:35:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joachim Frieben 2015-10-29 15:03:07 EDT
Description of problem:
I ran firefox in a sandbox using flash.
SELinux is preventing gvfsd-fuse from 'mounton' accesses on the directory /run/user/1000/gvfs.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that gvfsd-fuse should be allowed mounton access on the gvfs directory by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep gvfsd-fuse /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                unconfined_u:unconfined_r:sandbox_web_t:s0:c286,c6
                              40
Target Context                system_u:object_r:fusefs_t:s0
Target Objects                /run/user/1000/gvfs [ dir ]
Source                        gvfsd-fuse
Source Path                   gvfsd-fuse
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-152.fc23.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 4.2.3-300.fc23.x86_64 #1 SMP Mon
                              Oct 5 15:42:54 UTC 2015 x86_64 x86_64
Alert Count                   1
First Seen                    2015-10-29 19:55:17 CET
Last Seen                     2015-10-29 19:55:17 CET
Local ID                      5ceb846a-6fb2-4389-a0ce-8d113ff176ef

Raw Audit Messages
type=AVC msg=audit(1446144917.722:654): avc:  denied  { mounton } for  pid=4968 comm="gvfsd-fuse" path="/run/user/1000/gvfs" dev="fuse" ino=1 scontext=unconfined_u:unconfined_r:sandbox_web_t:s0:c286,c640 tcontext=system_u:object_r:fusefs_t:s0 tclass=dir permissive=1


Hash: gvfsd-fuse,sandbox_web_t,fusefs_t,dir,mounton

Version-Release number of selected component:
selinux-policy-3.13.1-152.fc23.noarch

Additional info:
reporter:       libreport-2.6.2
hashmarkername: setroubleshoot
kernel:         4.2.3-300.fc23.x86_64
type:           libreport
Comment 1 Miroslav Grepl 2016-01-22 08:35:39 EST

*** This bug has been marked as a duplicate of bug 1276462 ***

Note You need to log in before you can comment on or make changes to this bug.