Bug 1276494 - Anaconda hangs while restoring hardware time and probing storage
Anaconda hangs while restoring hardware time and probing storage
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
23
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-29 16:38 EDT by hkimura
Modified: 2015-10-30 20:15 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-30 20:15:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log files under /tmp (32.26 KB, application/octet-stream)
2015-10-30 15:10 EDT, hkimura
no flags Details
anaconda.log extracted from f23logs.tar.gz (14.71 KB, text/plain)
2015-10-30 16:00 EDT, Brian Lane
no flags Details
ifcfg.log extracted from f23logs.tar.gz (10.39 KB, text/plain)
2015-10-30 16:00 EDT, Brian Lane
no flags Details
program.log extracted from f23logs.tar.gz (26.03 KB, text/plain)
2015-10-30 16:00 EDT, Brian Lane
no flags Details
storage.log extracted from f23logs.tar.gz (202.05 KB, text/plain)
2015-10-30 16:00 EDT, Brian Lane
no flags Details

  None (edit)
Description hkimura 2015-10-29 16:38:44 EDT
Description of problem:
At the main hub I get an unrecoverable hang of the installer. Date & Time says Restoring hardware time, and Installation Destination shows probing storage...

Version-Release number of selected component (if applicable):
Fedora-Live-KDE-x86_64-23_Beta-1.iso

How reproducible:
Always. Tried 3 times. All hang at the same place.

Steps to Reproduce:
1. Create LiveUSB (done it on F21)
2. Reboot the machine and start LiveUSB
3. Start "install to disk"

Actual results:
Anaconda works

Expected results:
Hangs at the first page

Additional info:
This issue seems to have been reported a few times in earlier versions.
  https://bugzilla.redhat.com/show_bug.cgi?id=1111722
  https://bugzilla.redhat.com/show_bug.cgi?id=1167959
etc. The previous bug reports seem to say "fixed" (not sure what was the culprit) or "didn't reproduce" (maybe UEFI related?).
Comment 1 Brian Lane 2015-10-29 23:06:58 EDT
Please attach the logs from /tmp/*log as individual text/plain attachments.
Comment 2 hkimura 2015-10-30 15:10 EDT
Created attachment 1088011 [details]
log files under /tmp
Comment 3 hkimura 2015-10-30 15:10:56 EDT
Sure, attached. I appreciate taking a look.
Comment 4 Brian Lane 2015-10-30 16:00:17 EDT
Created attachment 1088017 [details]
anaconda.log extracted from f23logs.tar.gz
Comment 5 Brian Lane 2015-10-30 16:00:20 EDT
Created attachment 1088018 [details]
ifcfg.log extracted from f23logs.tar.gz
Comment 6 Brian Lane 2015-10-30 16:00:23 EDT
Created attachment 1088019 [details]
program.log extracted from f23logs.tar.gz
Comment 7 Brian Lane 2015-10-30 16:00:26 EDT
Created attachment 1088020 [details]
storage.log extracted from f23logs.tar.gz
Comment 8 Brian Lane 2015-10-30 16:02:52 EDT
How long did you wait? Looks like it is running e2fsck:

15:00:26,007 INFO program: Running... e2fsck -f -p -C 0 /dev/mapper/fedora_hkimura--z820-root
Comment 9 hkimura 2015-10-30 16:34:05 EDT
For this particular case, I just waited for 30 seconds and copied the logs.
In previous 3 times, I waited for several minutes before giving up.

Should I take the log again after waiting for, say, 15 minutes?
Comment 10 hkimura 2015-10-30 17:02:02 EDT
Ohh, this time I was watching the logs in program.log and found that it is making a progress, albeit super slowly. I just have too large disks on this machine, which will take hours to complete fsck.

Sorry, then this is not a bug... except that it'd be better to show what's going on there.

Probably it's the same request as this:
  https://bugzilla.redhat.com/show_bug.cgi?id=1170803

Note You need to log in before you can comment on or make changes to this bug.