This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1276498 - golang-1.5.1 broke vim plugin
golang-1.5.1 broke vim plugin
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: vim-go (Show other bugs)
21
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Nikola Forró
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-29 17:28 EDT by Eric
Modified: 2015-11-23 04:09 EST (History)
2 users (show)

See Also:
Fixed In Version: vim-go-1.2-1.fc21
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-23 04:09:53 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric 2015-10-29 17:28:33 EDT
Description of problem:

The last update of golang to 1.5.1 obsoleted golang-vim and vim-go is not available in F21

We need a backport from F22 please.

Thank you.
Comment 1 Fedora End Of Life 2015-11-04 05:01:04 EST
This message is a reminder that Fedora 21 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 21. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '21'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 21 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 2 Nikola Forró 2015-11-10 05:04:06 EST
Hi Eric,

actually vim-go should be available for F21:
https://bodhi.fedoraproject.org/updates/FEDORA-2015-12305
but for some reason the update didn't make it to any mirror.

I've rebased vim-go to the latest version and pushed new update for F21, so hopefully this will get resolved.
Comment 3 Nikola Forró 2015-11-12 03:13:18 EST
You can install vim-go-1.2-1.fc21 from updates-testing by running:

yum --enablerepo=updates-testing install vim-go

Then you can leave karma for the update here:
https://bodhi.fedoraproject.org/updates/FEDORA-2015-2dbb16ab2e
Comment 4 Nikola Forró 2015-11-23 04:09:53 EST
Package vim-go-1.2-1.fc21 is now available in stable, so I'm closing this bug.

Note You need to log in before you can comment on or make changes to this bug.