Bug 1276511 - [Docs] [Upgrade] Provide further clarification of the upgrade scenarios
[Docs] [Upgrade] Provide further clarification of the upgrade scenarios
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: documentation (Show other bugs)
7.0 (Kilo)
x86_64 Linux
medium Severity medium
: ---
: 8.0 (Liberty)
Assigned To: Deepti Navale
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-29 18:19 EDT by Arthur Enright
Modified: 2016-01-17 18:23 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-17 18:23:39 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Arthur Enright 2015-10-29 18:19:36 EDT
Description of problem: Document located here:

https://access.redhat.com/documentation/en/red-hat-enterprise-linux-openstack-platform/version-7/upgrading-openstack/

The abstract states:

This document lays out the different methods through which users can upgrade from Red Hat Enterprise Linux OpenStack Platform 6 (Juno) to 7 (Kilo). These methods assume that you will be upgrading to and from an OpenStack deployment installed on Red Hat Enterprise Linux 7.

But the document is clearly for upgrading 7.0 -> 7.1

The abstract needs to be udpated


Version-Release number of selected component (if applicable): 7


How reproducible: 100%


Steps to Reproduce:
1. Pull up the Access article and read the abstract
2.
3.

Actual results:

Abstract claims upgrade from 6->7


Expected results:

Abstract states upgrade from 7->7.1


Additional info:
Comment 2 Andrew Dahms 2015-10-30 03:21:11 EDT
Hi Arthur,

Thank you for raising this bug.

Just to clarify, the intent of this document is indeed to assist users in upgrading from RHEL-OSP 6 to RHEL-OSP 7 rather than from RHEL-OSP 7.0 to RHEL-OSP 7.1.

Are there any particular aspects of the document that you feel do not fit with this scenario, or that may seem misleading to the reader?

Let me know what you think, and we will investigate.

Kind regards,

Andrew
Comment 3 Arthur Enright 2015-10-30 09:52:29 EDT
Thanks Andrew,

I reviewed chapter 3 which appears to be specific to 7->7.1 it looks like chapter 4 applies to 6->7  Can you confirm this?

Thanks!
-Art
Comment 4 Andrew Dahms 2015-11-01 18:25:45 EST
Hi Arthur,

Thank you for your response.

I can confirm that Chapter 3 is also intended as an upgrade path from RHEL-OSP 6 to RHEL-OSP 7. However, I do agree that the note early in this chapter about the possibly need to upgrade from RHEL 7.0 to RHEL 7.1 might be a point of confusion here.

Would it help if we called out the purpose of the scenario a little more clearly at the start of the chapter and talked a little more about the RHEL upgrade as well?

Let me know what you think.

Kind regards,

Andrew
Comment 5 Arthur Enright 2015-11-02 09:38:25 EST
Andrew,

That would be great!

Thanks!
-Art
Comment 6 Andrew Dahms 2015-11-11 09:37:05 EST
Assigning to Deepti for review.

Deepti - would you be able to add some clarification as per the comments above? Let me know if you have any questions.
Comment 8 Deepti Navale 2015-11-30 01:33:38 EST
Sent an email reminder to Arthur for update review.
Comment 10 Deepti Navale 2016-01-05 23:12:38 EST
Content merged. Changing status to VERIFIED.
Comment 12 Andrew Dahms 2016-01-17 18:23:39 EST
This content is live on the Customer Portal.

Closing.

Note You need to log in before you can comment on or make changes to this bug.