Bug 1276517 - libdatrie does not mock build on Fedora 23
libdatrie does not mock build on Fedora 23
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libdatrie (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peng Wu
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-29 19:29 EDT by David Sommerseth
Modified: 2016-05-22 19:35 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-14 23:46:29 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fix building issues on Fedora 23 (1.88 KB, text/plain)
2015-10-29 19:29 EDT, David Sommerseth
no flags Details

  None (edit)
Description David Sommerseth 2015-10-29 19:29:37 EDT
Created attachment 1087783 [details]
Fix building issues on Fedora 23

When doing mock build against the Fedora 23 profile, rpmbuild complained about missing packaging of /usr/bin/trietool-0.2 and a man page with the same name (both being symlinks) and some developers documenation.

The attached patch fixes this by removing the man page symlink and explicitly package all trietool files in /usr/bin.  Also expliclty packaged the developer docs.
Comment 1 Christopher Meng 2015-10-30 05:01:11 EDT
I might understand what you were trying to explain here ;) But f23 has no plan for 0.2.9.

I didn't update the libdatrie in f24 as well, because I didn't fix the spec. I will fix it soon.
Comment 2 Peng Wu 2016-01-14 23:46:29 EST
built in rawhide.

http://koji.fedoraproject.org/koji/buildinfo?buildID=679995

Note You need to log in before you can comment on or make changes to this bug.