Bug 1276540 - virt-v2v fails to convert Windows raw image: error "device name is not a partition"
virt-v2v fails to convert Windows raw image: error "device name is not a part...
Status: CLOSED UPSTREAM
Product: Virtualization Tools
Classification: Community
Component: libguestfs (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Richard W.M. Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-30 00:51 EDT by kwsk
Modified: 2015-11-03 05:15 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-30 04:55:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log (412.15 KB, text/plain)
2015-10-30 00:51 EDT, kwsk
no flags Details

  None (edit)
Description kwsk 2015-10-30 00:51:36 EDT
Created attachment 1087812 [details]
log

Description of problem:

libguestfs: trace: pread_device = "NTFS    "
libguestfs: trace: part_to_dev "/dev/sda"
guestfsd: main_loop: new request, len 0x34
guestfsd: error: device name is not a partition
guestfsd: main_loop: proc 272 (part_to_dev) took 0.00 seconds
libguestfs: trace: part_to_dev = NULL (error)
virt-v2v: error: libguestfs error: part_to_dev: device name is not a
partition

Version-Release number of selected component (if applicable):


How reproducible:

Always

Steps to Reproduce:
1. virt-v2v -v -x -i disk dump.img -o local -os ./result
   ( dump.img is Windows raw image)
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Richard W.M. Jones 2015-10-30 04:45:46 EDT
While it's definitely a bug, and I'll post a fix for it soon,
is this image bootable?  As far as I know, Windows cannot work
without a partition table.
Comment 2 Richard W.M. Jones 2015-10-30 04:55:56 EDT
Fixed upstream:

https://github.com/libguestfs/libguestfs/commit/20ae8bd9ec9fdc3c8ffe939185017fb6ae11f8c1

The fix will appear in 1.30.5 & 1.31.21.
Comment 3 kwsk 2015-10-30 08:43:51 EDT
After git pull, Failed to convert another reason
mount: unknown filesystem type 'ntfs'

libguestfs: trace: v2v: is_whole_device "/dev/sda"
guestfsd: main_loop: new request, len 0x34
guestfsd: main_loop: proc 395 (is_whole_device) took 0.00 seconds
libguestfs: trace: v2v: is_whole_device = 1
libguestfs: trace: v2v: isoinfo_device "/dev/sda"
guestfsd: main_loop: new request, len 0x34
isoinfo --debug -d -i /dev/sda
guestfsd: error:
guestfsd: main_loop: proc 313 (isoinfo_device) took 0.00 seconds
libguestfs: trace: v2v: isoinfo_device = NULL (error)
libguestfs: trace: v2v: mount_ro "/dev/sda" "/"
guestfsd: main_loop: new request, len 0x3c
mount -o ro /dev/sda /sysroot/
mount: unknown filesystem type 'ntfs'
guestfsd: error: /dev/sda on / (options: 'ro'): mount: unknown filesystem type 'ntfs'
guestfsd: main_loop: proc 73 (mount_ro) took 0.00 seconds
libguestfs: trace: v2v: mount_ro = -1 (error)
libguestfs: trace: v2v: inspect_get_roots
libguestfs: trace: v2v: inspect_get_roots = []
libguestfs: trace: v2v: inspect_os = []
virt-v2v: error: no root device found in this operating system image.
libguestfs: trace: v2v: close
libguestfs: closing guestfs handle 0xb06ef0 (state 2)
libguestfs: trace: v2v: internal_autosync
guestfsd: main_loop: new request, len 0x28
umount-all: /proc/mounts: fsname=rootfs dir=/ type=rootfs opts=rw freq=0 passno=0
umount-all: /proc/mounts: fsname=proc dir=/proc type=proc opts=rw,relatime freq=0 passno=0
umount-all: /proc/mounts: fsname=/dev/root dir=/ type=ext2 opts=rw,noatime freq=0 passno=0
umount-all: /proc/mounts: fsname=/proc dir=/proc type=proc opts=rw,relatime freq=0 passno=0
umount-all: /proc/mounts: fsname=/sys dir=/sys type=sysfs opts=rw,relatime freq=0 passno=0
umount-all: /proc/mounts: fsname=tmpfs dir=/run type=tmpfs opts=rw,nosuid,relatime,size=97772k,mode=755 freq=0 passno=0
umount-all: /proc/mounts: fsname=/dev dir=/dev type=devtmpfs opts=rw,relatime,size=242012k,nr_inodes=60503,mode=755 freq=0 passno=0
fsync /dev/sda
Comment 4 Richard W.M. Jones 2015-10-30 10:18:19 EDT
You probably need to install libguestfs-ntfs (Fedora/Debian) or
libguestfs-winsupport (RHEL).
Comment 5 kwsk 2015-11-01 20:04:39 EST
Already installed libguestfs-winsupport

[root@localhost ~]# rpm -qa | grep winsupport
libguestfs-winsupport-7.2-1.el7.x86_64

while Device name is /dev/sda, I thinke fs is /dev/sda1
Comment 6 kwsk 2015-11-01 20:54:39 EST
I copied zz-winsupport.tar.gz to appliance/supermin.d/
and got another error

libguestfs: trace: v2v: inspect_os = NULL (error)
virt-v2v: error: libguestfs error: hivex_open: feature 'hivex' is not
available in this
build of libguestfs.  Read 'AVAILABILITY' in the guestfs(3) man page for
how to check for the availability of features.
libguestfs: trace: v2v: close
libguestfs: closing guestfs handle 0x1997ef0 (state 2)
libguestfs: trace: v2v: internal_autosync
Comment 7 kwsk 2015-11-01 21:22:17 EST
After remake with path to hivex
and got error below
guestfsd: error: not a partitioned device

But, It was successful to get registry value with hivex

libguestfs: trace: v2v: list_devices
guestfsd: main_loop: proc 351 (hivex_close) took 0.00 seconds
guestfsd: main_loop: new request, len 0x28
guestfsd: main_loop: proc 7 (list_devices) took 0.00 seconds
libguestfs: trace: v2v: list_devices = ["/dev/sda"]
libguestfs: trace: v2v: part_get_parttype "/dev/sda"
guestfsd: main_loop: new request, len 0x34
parted -m -s -- /dev/sda unit b print
guestfsd: error: not a partitioned device
guestfsd: main_loop: proc 214 (part_get_parttype) took 0.01 seconds
libguestfs: trace: v2v: part_get_parttype = NULL (error)
virt-v2v: error: libguestfs error: part_get_parttype: not a partitioned
device
libguestfs: trace: v2v: close
Comment 8 kwsk 2015-11-01 21:49:56 EST
There was some offset between ok and ng pattern

NG:
00000000   EB 52 90 4E  54 46 53 20  20 20 20 00  02 08 00 00  .R.NTFS    .....
00000010   00 00 00 00  00 F8 00 00  3F 00 FF 00  00 08 00 00  ........?.......
00000020   00 00 00 00  80 00 80 00  FF EF BF 03  00 00 00 00  ................
00000030   00 00 0C 00  00 00 00 00  02 00 00 00  00 00 00 00  ................
00000040   F6 00 00 00  01 00 00 00  6C 74 D1 36  99 D1 36 1C  ........lt.6..6.
00000050   00 00 00 00  FA 33 C0 8E  D0 BC 00 7C  FB 68 C0 07  .....3.....|.h..
00000060   1F 1E 68 66  00 CB 88 16  0E 00 66 81  3E 03 00 4E  ..hf......f.>..N
00000070   54 46 53 75  15 B4 41 BB  AA 55 CD 13  72 0C 81 FB  TFSu..A..U..r...
00000080   55 AA 75 06  F7 C1 01 00  75 03 E9 DD  00 1E 83 EC  U.u.....u.......
00000090   18 68 1A 00  B4 48 8A 16  0E 00 8B F4  16 1F CD 13  .h...H..........


OK:
00000000   33 C0 8E D0  BC 00 7C 8E  C0 8E D8 BE  00 7C BF 00  3.....|......|..
00000010   06 B9 00 02  FC F3 A4 50  68 1C 06 CB  FB B9 04 00  .......Ph.......
00000020   BD BE 07 80  7E 00 00 7C  0B 0F 85 0E  01 83 C5 10  ....~..|........
00000030   E2 F1 CD 18  88 56 00 55  C6 46 11 05  C6 46 10 00  .....V.U.F...F..
00000040   B4 41 BB AA  55 CD 13 5D  72 0F 81 FB  55 AA 75 09  .A..U..]r...U.u.
00000050   F7 C1 01 00  74 03 FE 46  10 66 60 80  7E 10 00 74  ....t..F.f`.~..t
00000060   26 66 68 00  00 00 00 66  FF 76 08 68  00 00 68 00  &fh....f.v.h..h.
00000070   7C 68 01 00  68 10 00 B4  42 8A 56 00  8B F4 CD 13  |h..h...B.V.....
00000080   9F 83 C4 10  9E EB 14 B8  01 02 BB 00  7C 8A 56 00  ............|.V.
00000090   8A 76 01 8A  4E 02 8A 6E  03 CD 13 66  61 73 1C FE  .v..N..n...fas..
Comment 9 Richard W.M. Jones 2015-11-03 05:15:48 EST
It's probably best to discuss these things on the mailing list
instead of on a closed bug.

Since I've no idea what you're trying to do, in your mailing
list posting please explain in detail the precise steps you're
doing, what version of libguestfs you are using, what host OS
you are using, what guest you're trying to convert and so on.

Note You need to log in before you can comment on or make changes to this bug.