Bug 1276623 - Not possible to list errata from channel by last modified date
Not possible to list errata from channel by last modified date
Status: CLOSED ERRATA
Product: Red Hat Satellite 5
Classification: Red Hat
Component: API (Show other bugs)
570
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jan Dobes
Radovan Drazny
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-30 06:25 EDT by Jan Dobes
Modified: 2015-11-23 04:02 EST (History)
4 users (show)

See Also:
Fixed In Version: spacewalk-java-2.3.8-118
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-23 04:02:44 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Dobes 2015-10-30 06:25:04 EDT
Description of problem:
rhn-satellite-exporter can create partial dump of channel with content limited by interval, it exports all data by last modified date. When we want to verify this content, we use API with same interval as parameter. API call channel.software.listErrata returns different result because it was changed to list by issue date instead of last modified date.

Version-Release number of selected component (if applicable):
spacewalk-java-2.3.8-116

How reproducible:
always

Steps to Reproduce:
1. Create dump with rhn-satellite-exporter with both --start-date and --end-date parameters.
2. Compare exported errata and errata returned by channel.software.listErrata API with same interval as parameter.

Actual results:
Errata does not match. API list errata only by issue date.

Expected results:
Errata does match. API can list errata by last modified date.

Additional info:
Working in Satellite 5.4
Comment 1 Jan Dobes 2015-10-30 06:27:18 EDT
fixed in spacewalk master by adding additional parameter:

80086386e7bae589d4af6863bb0e54d93c3d9cb0
c6a001a5949fe41045f8be1cf0ea20da5b71b17a
Comment 8 Radovan Drazny 2015-11-12 04:25:12 EST
Tested on Sat 5.7, both Postgresql and Oracle db backend. 
 - Updated to spacewalk-java-2.3.8-119.el6sat
 - Did a new export with same parameters as in comment 6
 - Did an API call with new signature (listErrata(key2, channel, startDate, endDate, True)), where last boolean True forces use of last modified date. 
 - Compared results of export and API call. Both contain 481 erratas, and are identical. 
 - Verified.
Comment 10 errata-xmlrpc 2015-11-23 04:02:44 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2503.html

Note You need to log in before you can comment on or make changes to this bug.