Bug 127665 - up2date cant find package files
up2date cant find package files
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: up2date (Show other bugs)
2.1
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Adrian Likins
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-12 07:25 EDT by Martin Schmachtel
Modified: 2007-11-30 17:06 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-26 15:14:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Schmachtel 2004-07-12 07:25:28 EDT
Description of problem:

Trying to run up2date -l on Redhat AS 2.1 results in the following
output:

[root@localhost root]# up2date -l
gpg: WARNING: --honor-http-proxy is a deprecated option.
gpg: please use "--keyserver-options honor-http-proxy" instead
gpg: WARNING: --honor-http-proxy is a deprecated option.
gpg: please use "--keyserver-options honor-http-proxy" instead
gpg: WARNING: --honor-http-proxy is a deprecated option.
gpg: please use "--keyserver-options honor-http-proxy" instead
gpg: WARNING: --honor-http-proxy is a deprecated option.
gpg: please use "--keyserver-options honor-http-proxy" instead

Fetching package list for channel: redhat-advanced-server-i386...
########################################

Fetching Obsoletes list for channel: redhat-advanced-server-i386...
########################################

Fetching rpm headers...
##############################
Error Message:
    Package not found
Error Class Code: 17
Error Class Info: File not found.
Explanation:
     An error has occurred while processing your request. If this 
problem
     persists please enter a bug report at bugzilla.redhat.com.
     If you choose to submit the bug report, please be sure to include
     details of what you were trying to do when this error occurred 
and
     details on how to reproduce this problem.

[root@localhost root]#

Trying to run up2date under the gui results in the same behaviour.

I have set useNoSSLForPackages=1 temporarily and saved the network
traffic with ethereal. This is what was communicated (Auth-Info 
snipped, can be sent on request):

GET /XMLRPC/$RHN/redhat-advanced-server-i386/getPackageHeader/redhat-
release-as-
2.1AS-11.noarch.hdr HTTP/1.1
Host: www.rhns.redhat.com
Accept-Encoding: identity
X-Info: RPC Processor (C) Red Hat, Inc (version 1.41)
[... Auth Info ...]
User-Agent: rhn.rpclib.py/$Revision: 1.33 $
X-Up2date-Version: 2.9.3,2.9.3,2.9.3,2.9.3,2.9.3,2.9.3
X-Transport-Info: Extended Capabilities Transport (C) Red Hat, Inc 
(version 1.33
)
X-RHN-Server-Id: 1004587252
X-Client-Version: 1
X-RHN-Transport-Capability: follow-redirects=1

HTTP/1.1 404 Not Found
Date: Mon, 12 Jul 2004 09:55:45 GMT
Server: Apache
X-RHN-Fault-Code: -17
X-RHN-Fault-String: 
CkVycm9yIE1lc3NhZ2U6CiAgICBQYWNrYWdlIG5vdCBmb3VuZApFcnJvciBD
bGFzcyBDb2RlOiAx
X-RHN-Fault-String: 
NwpFcnJvciBDbGFzcyBJbmZvOiBGaWxlIG5vdCBmb3VuZC4KRXhwbGFuYXRp
b246IAogICAgIEFu
X-RHN-Fault-String: 
IGVycm9yIGhhcyBvY2N1cnJlZCB3aGlsZSBwcm9jZXNzaW5nIHlvdXIgcmVx
dWVzdC4gSWYgdGhp
X-RHN-Fault-String: 
cyBwcm9ibGVtCiAgICAgcGVyc2lzdHMgcGxlYXNlIGVudGVyIGEgYnVnIHJl
cG9ydCBhdCBidWd6
X-RHN-Fault-String: 
aWxsYS5yZWRoYXQuY29tLgogICAgIElmIHlvdSBjaG9vc2UgdG8gc3VibWl0
IHRoZSBidWcgcmVw
X-RHN-Fault-String: 
b3J0LCBwbGVhc2UgYmUgc3VyZSB0byBpbmNsdWRlCiAgICAgZGV0YWlscyBv
ZiB3aGF0IHlvdSB3
X-RHN-Fault-String: 
ZXJlIHRyeWluZyB0byBkbyB3aGVuIHRoaXMgZXJyb3Igb2NjdXJyZWQgYW5k
CiAgICAgZGV0YWls
X-RHN-Fault-String: cyBvbiBob3cgdG8gcmVwcm9kdWNlIHRoaXMgcHJvYmxlbS4K
X-RHN-Client-Version: 1
X-RHN-Proxy-Version: 0
Content-Type: text/html; charset=iso-8859-1
Via: 1.1 xmlrpc.rhn.redhat.com


This makes it impossible to update any of the packages


Version-Release number of selected component (if applicable):

up2date-2.9.3-2.2.1AS

How reproducible:

Always

Steps to Reproduce:

1. Run up2date -l

Actual results:

see above

Expected results:

output a list of updated packages

Additional info:

serverURL=https://www.rhns.redhat.com/XMLRPC

Same happens of course with up2date -u
Comment 1 Suzanne Hillman 2004-07-15 15:36:30 EDT
This looks like something for which you would be best off going
through support:

https://www.redhat.com/apps/support/
Comment 2 Martin Schmachtel 2004-07-19 04:06:14 EDT
now everything works again without a change on my systems. Ist must 
have been a temporary problem on redhats end.

Note You need to log in before you can comment on or make changes to this bug.