Bug 1276682 - Installing opendnssec complains about line 3: softhsm: command not found
Installing opendnssec complains about line 3: softhsm: command not found
Status: CLOSED EOL
Product: Fedora
Classification: Fedora
Component: opendnssec (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Paul Wouters
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-30 09:40 EDT by Jan Pazdziora
Modified: 2016-07-19 14:22 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-19 14:22:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Pazdziora 2015-10-30 09:40:44 EDT
Description of problem:

Scriptlet of openddnssec calls softhsm command which does not seem to exist.

Version-Release number of selected component (if applicable):

opendnssec-1.4.7-1.fc22.x86_64

How reproducible:

Deterministic.

Steps to Reproduce:
1. dnf install -y opendnssec

Actual results:

  Installing  : softhsm-2.0.0b1-3.fc22.x86_64                               6/8 
  Installing  : libxslt-1.1.28-8.fc22.x86_64                                7/8 
  Installing  : opendnssec-1.4.7-1.fc22.x86_64                              8/8 
/var/tmp/rpm-tmp.XdedLa: line 3: softhsm: command not found
  Verifying   : opendnssec-1.4.7-1.fc22.x86_64                              1/8 
  Verifying   : ldns-1.6.17-12.fc22.x86_64                                  2/8 
  Verifying   : libxslt-1.1.28-8.fc22.x86_64                                3/8 

Expected results:

  Installing  : softhsm-2.0.0b1-3.fc22.x86_64                               6/8 
  Installing  : libxslt-1.1.28-8.fc22.x86_64                                7/8 
  Installing  : opendnssec-1.4.7-1.fc22.x86_64                              8/8 
  Verifying   : opendnssec-1.4.7-1.fc22.x86_64                              1/8 
  Verifying   : ldns-1.6.17-12.fc22.x86_64                                  2/8 
  Verifying   : libxslt-1.1.28-8.fc22.x86_64                                3/8 

Additional info:

rpm -q --scripts opendnssec shows

postinstall scriptlet (using /bin/sh):
# Initialise a slot on the softhsm on first install
if [ "$1" -eq 1 ]; then
        softhsm --init-token --slot 0 --label "OpenDNSSEC" --pin 1234 --so-pin 1234
fi

That softhsm command does not seem to exist:

# rpm -q softhsm
softhsm-2.0.0b1-3.fc22.x86_64
# rpm -ql softhsm | grep bin
/usr/bin/softhsm2-dump-file
/usr/bin/softhsm2-keyconv
/usr/bin/softhsm2-migrate
/usr/bin/softhsm2-pk11install
/usr/bin/softhsm2-util
Comment 1 Fedora End Of Life 2016-07-19 14:22:28 EDT
Fedora 22 changed to end-of-life (EOL) status on 2016-07-19. Fedora 22 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.