Bug 1276719 - SELinux is preventing abrt-hook-ccpp from 'getattr' accesses on the file /usr/sbin/NetworkManager.
SELinux is preventing abrt-hook-ccpp from 'getattr' accesses on the file /usr...
Status: CLOSED DUPLICATE of bug 1274963
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
rawhide
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:9b74f65ddeff3d5d03cdedc1f2e...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-30 11:59 EDT by Joachim Frieben
Modified: 2015-11-09 05:47 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-09 05:47:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joachim Frieben 2015-10-30 11:59:55 EDT
Description of problem:
SELinux is preventing abrt-hook-ccpp from 'getattr' accesses on the file /usr/sbin/NetworkManager.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that abrt-hook-ccpp should be allowed getattr access on the NetworkManager file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep abrt-hook-ccpp /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:abrt_dump_oops_t:s0
Target Context                system_u:object_r:NetworkManager_exec_t:s0
Target Objects                /usr/sbin/NetworkManager [ file ]
Source                        abrt-hook-ccpp
Source Path                   abrt-hook-ccpp
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           NetworkManager-1.2.0-0.3.20151023gite01c175.fc24.x
                              86_64
Policy RPM                    selinux-policy-3.13.1-156.fc24.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 4.3.0-0.rc7.git2.2.fc24.x86_64 #1
                              SMP Wed Oct 28 19:23:26 UTC 2015 x86_64 x86_64
Alert Count                   2
First Seen                    2015-10-30 16:41:27 CET
Last Seen                     2015-10-30 16:47:36 CET
Local ID                      2e494243-81ae-4e26-a91e-aaa325c1ff89

Raw Audit Messages
type=AVC msg=audit(1446220056.464:645): avc:  denied  { getattr } for  pid=4485 comm="abrt-hook-ccpp" path="/usr/sbin/NetworkManager" dev="dm-0" ino=413891 scontext=system_u:system_r:abrt_dump_oops_t:s0 tcontext=system_u:object_r:NetworkManager_exec_t:s0 tclass=file permissive=0


Hash: abrt-hook-ccpp,abrt_dump_oops_t,NetworkManager_exec_t,file,getattr

Version-Release number of selected component:
selinux-policy-3.13.1-156.fc24.noarch

Additional info:
reporter:       libreport-2.6.3
hashmarkername: setroubleshoot
kernel:         4.3.0-0.rc7.git2.2.fc24.x86_64
type:           libreport

Potential duplicate: bug 1274313
Comment 1 Miroslav Grepl 2015-11-09 05:47:47 EST

*** This bug has been marked as a duplicate of bug 1274963 ***

Note You need to log in before you can comment on or make changes to this bug.