Bug 1276730 - [git checkout v1.2.20] Cannot start libvirt
[git checkout v1.2.20] Cannot start libvirt
Status: CLOSED NEXTRELEASE
Product: Virtualization Tools
Classification: Community
Component: libvirt (Show other bugs)
unspecified
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Libvirt Maintainers
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-30 12:42 EDT by jean-christophe manciot
Modified: 2015-11-05 04:05 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-05 04:05:46 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jean-christophe manciot 2015-10-30 12:42:04 EDT
Description of problem:
----------------------
Libvirt 1.2.20 tarball is different from libvirt git checkout v1.2.20.
The latter libvirt cannot be started.

On Ubuntu 15.04:
- with git checkout 439760214c1d302f5508063d24c1ffc496ed9735, (v1.2.20 tag)
systemctl status libvirt-bin
● libvirt-bin.service - LSB: libvirt management daemon
   Loaded: loaded (/etc/init.d/libvirt-bin)
   Active: failed (Result: exit-code) since Fri 2015-10-30 16:16:05 CET; 50min ago
     Docs: man:systemd-sysv-generator(8)
  Process: 1519 ExecStart=/etc/init.d/libvirt-bin start (code=exited, status=1/FAILURE)

Oct 30 16:15:55 msi-ge60-ubuntu libvirt-bin[1519]: Waiting for /var/run/libvirt/libvirt-sock - recheck in 2 sec
Oct 30 16:15:57 msi-ge60-ubuntu libvirt-bin[1519]: Waiting for /var/run/libvirt/libvirt-sock - recheck in 2 sec
Oct 30 16:15:59 msi-ge60-ubuntu libvirt-bin[1519]: Waiting for /var/run/libvirt/libvirt-sock - recheck in 2 sec
Oct 30 16:16:01 msi-ge60-ubuntu libvirt-bin[1519]: Waiting for /var/run/libvirt/libvirt-sock - recheck in 2 sec
Oct 30 16:16:03 msi-ge60-ubuntu libvirt-bin[1519]: Waiting for /var/run/libvirt/libvirt-sock - recheck in 2 sec
Oct 30 16:16:05 msi-ge60-ubuntu libvirt-bin[1519]: Giving up waiting for /var/run/libvirt/libvirt-sock.
Oct 30 16:16:05 msi-ge60-ubuntu systemd[1]: libvirt-bin.service: control process exited, code=exited status=1
Oct 30 16:16:05 msi-ge60-ubuntu systemd[1]: Failed to start LSB: libvirt management daemon.
Oct 30 16:16:05 msi-ge60-ubuntu systemd[1]: Unit libvirt-bin.service entered failed state.
Oct 30 16:16:05 msi-ge60-ubuntu systemd[1]: libvirt-bin.service failed.
root@msi-ge60-ubuntu:/usr/share/applications# systemctl stop libvirt-bin
root@msi-ge60-ubuntu:/usr/share/applications# systemctl start libvirt-bin
Job for libvirt-bin.service failed. See "systemctl status libvirt-bin.service" and "journalctl -xe" for details.

- from libvirt tarball 1.2.20:
systemctl status libvirt-bin
● libvirt-bin.service - LSB: libvirt management daemon
   Loaded: loaded (/etc/init.d/libvirt-bin)
   Active: active (running) since Fri 2015-10-30 17:35:19 CET; 1min 24s ago
     Docs: man:systemd-sysv-generator(8)
   CGroup: /system.slice/libvirt-bin.service
           ├─4973 /usr/sbin/libvirtd -d
           ├─6178 /usr/sbin/dnsmasq --conf-file=/var/lib/libvirt/dnsmasq/virtual-router.conf --leasefile-ro --dhcp-script=/usr/libexec/libvirt_leas...
           ├─6179 /usr/sbin/dnsmasq --conf-file=/var/lib/libvirt/dnsmasq/virtual-router.conf --leasefile-ro --dhcp-script=/usr/libexec/libvirt_leas...
           ├─6257 /usr/sbin/dnsmasq --conf-file=/var/lib/libvirt/dnsmasq/default.conf --leasefile-ro --dhcp-script=/usr/libexec/libvirt_leaseshelpe...
           ├─6258 /usr/sbin/dnsmasq --conf-file=/var/lib/libvirt/dnsmasq/default.conf --leasefile-ro --dhcp-script=/usr/libexec/libvirt_leaseshelpe...
           ├─6331 /usr/sbin/dnsmasq --conf-file=/var/lib/libvirt/dnsmasq/virtual-bridge-7.conf --leasefile-ro --dhcp-script=/usr/libexec/libvirt_le...
           ├─6332 /usr/sbin/dnsmasq --conf-file=/var/lib/libvirt/dnsmasq/virtual-bridge-7.conf --leasefile-ro --dhcp-script=/usr/libexec/libvirt_le...
           ├─6403 /usr/sbin/dnsmasq --conf-file=/var/lib/libvirt/dnsmasq/virtual-bridge-8.conf --leasefile-ro --dhcp-script=/usr/libexec/libvirt_le...
           ├─6404 /usr/sbin/dnsmasq --conf-file=/var/lib/libvirt/dnsmasq/virtual-bridge-8.conf --leasefile-ro --dhcp-script=/usr/libexec/libvirt_le...
           ├─6494 /usr/sbin/dnsmasq --conf-file=/var/lib/libvirt/dnsmasq/virtual-bridge-6.conf --leasefile-ro --dhcp-script=/usr/libexec/libvirt_le...
           ├─6495 /usr/sbin/dnsmasq --conf-file=/var/lib/libvirt/dnsmasq/virtual-bridge-6.conf --leasefile-ro --dhcp-script=/usr/libexec/libvirt_le...
           ├─6618 /usr/sbin/dnsmasq --conf-file=/var/lib/libvirt/dnsmasq/virtual-bridge-1.conf --leasefile-ro --dhcp-script=/usr/libexec/libvirt_le...
           ├─6619 /usr/sbin/dnsmasq --conf-file=/var/lib/libvirt/dnsmasq/virtual-bridge-1.conf --leasefile-ro --dhcp-script=/usr/libexec/libvirt_le...
           ├─6721 /usr/sbin/dnsmasq --conf-file=/var/lib/libvirt/dnsmasq/loopback.conf --leasefile-ro --dhcp-script=/usr/libexec/libvirt_leaseshelp...
           ├─6722 /usr/sbin/dnsmasq --conf-file=/var/lib/libvirt/dnsmasq/loopback.conf --leasefile-ro --dhcp-script=/usr/libexec/libvirt_leaseshelp...
           ├─6794 /usr/sbin/dnsmasq --conf-file=/var/lib/libvirt/dnsmasq/virtual-bridge-5.conf --leasefile-ro --dhcp-script=/usr/libexec/libvirt_le...
           ├─6795 /usr/sbin/dnsmasq --conf-file=/var/lib/libvirt/dnsmasq/virtual-bridge-5.conf --leasefile-ro --dhcp-script=/usr/libexec/libvirt_le...
           ├─6869 /usr/sbin/dnsmasq --conf-file=/var/lib/libvirt/dnsmasq/virtual-bridge-4.conf --leasefile-ro --dhcp-script=/usr/libexec/libvirt_le...
           ├─6870 /usr/sbin/dnsmasq --conf-file=/var/lib/libvirt/dnsmasq/virtual-bridge-4.conf --leasefile-ro --dhcp-script=/usr/libexec/libvirt_le...
           ├─6942 /usr/sbin/dnsmasq --conf-file=/var/lib/libvirt/dnsmasq/virtual-bridge-9.conf --leasefile-ro --dhcp-script=/usr/libexec/libvirt_le...
           ├─6943 /usr/sbin/dnsmasq --conf-file=/var/lib/libvirt/dnsmasq/virtual-bridge-9.conf --leasefile-ro --dhcp-script=/usr/libexec/libvirt_le...
           ├─7030 /usr/sbin/dnsmasq --conf-file=/var/lib/libvirt/dnsmasq/virtual-bridge-3.conf --leasefile-ro --dhcp-script=/usr/libexec/libvirt_le...
           ├─7031 /usr/sbin/dnsmasq --conf-file=/var/lib/libvirt/dnsmasq/virtual-bridge-3.conf --leasefile-ro --dhcp-script=/usr/libexec/libvirt_le...
           ├─7104 /usr/sbin/dnsmasq --conf-file=/var/lib/libvirt/dnsmasq/virtual-bridge-2.conf --leasefile-ro --dhcp-script=/usr/libexec/libvirt_le...
           └─7105 /usr/sbin/dnsmasq --conf-file=/var/lib/libvirt/dnsmasq/virtual-bridge-2.conf --leasefile-ro --dhcp-script=/usr/libexec/libvirt_le...

Oct 30 17:35:25 msi-ge60-ubuntu dnsmasq-dhcp[7104]: DHCP, IP range 172.20.100.128 -- 172.20.100.254, lease time 1h
Oct 30 17:35:25 msi-ge60-ubuntu dnsmasq-dhcp[7104]: DHCPv6, IP range fc20:100::100 -- fc20:100::1ff, lease time 1h
Oct 30 17:35:25 msi-ge60-ubuntu dnsmasq-dhcp[7104]: router advertisement on fc20:100::
Oct 30 17:35:25 msi-ge60-ubuntu dnsmasq-dhcp[7104]: IPv6 router advertisement enabled
Oct 30 17:35:25 msi-ge60-ubuntu dnsmasq-dhcp[7104]: DHCP, sockets bound exclusively to interface virbr4
Oct 30 17:35:25 msi-ge60-ubuntu dnsmasq[7104]: read /etc/hosts - 10 addresses
Oct 30 17:35:25 msi-ge60-ubuntu dnsmasq[7104]: read /var/lib/libvirt/dnsmasq/virtual-bridge-2.addnhosts - 0 addresses
Oct 30 17:35:25 msi-ge60-ubuntu dnsmasq-dhcp[7104]: read /var/lib/libvirt/dnsmasq/virtual-bridge-2.hostsfile
Comment 1 jean-christophe manciot 2015-11-05 04:05:26 EST
Solved in 1.2.21

Note You need to log in before you can comment on or make changes to this bug.