Bug 1276758 - Latest refresh status is 'Never' when admin user is not added to tenants
Latest refresh status is 'Never' when admin user is not added to tenants
Status: CLOSED NOTABUG
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers (Show other bugs)
5.4.0
Unspecified Unspecified
medium Severity medium
: GA
: 5.6.0
Assigned To: Greg Blomquist
Dave Johnson
tenant
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-30 14:43 EDT by Max Whittingham
Modified: 2016-05-27 19:38 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-27 19:38:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Max Whittingham 2015-10-30 14:43:14 EDT
Description of problem:
cloud instance refresh status states 'Never' if admin user is not added to tenants.

Version-Release number of selected component (if applicable):
5.4.2

How reproducible:


Steps to Reproduce:
1. Add cloud instance to cloudforms without admin user present in any of the tenants
2. Trigger a manual refresh

Actual results:
latest refresh status: never

Expected results:
latest refresh status: $sometime

Additional info:
Comment 2 Greg Blomquist 2016-02-19 16:21:35 EST
Max, this is actually a requirement for now that the OpenStack API user credentials used by CFME must be added to all of the  tenants from which you want to collect data.

Loic, I believe you've double checked with the core OSP engineers and they have validated that this is required, correct?
Comment 3 Loic Avenel 2016-02-20 05:41:22 EST
(In reply to Greg Blomquist from comment #2)
> Max, this is actually a requirement for now that the OpenStack API user
> credentials used by CFME must be added to all of the  tenants from which you
> want to collect data.
> 
> Loic, I believe you've double checked with the core OSP engineers and they
> have validated that this is required, correct?

There are 2 things here: By design, admin user (if used to connect from CloudForms to OpenStack) then it must be part of any tenant we want to see from CloudForms, this is by design, tenant are like fences...

In 5.4, I did experience this issue when you have a tenant where admin is not a member then refresh fails. I did the same test with 5.5 and was not failing, we simply don't see the tenant...
Comment 5 Loic Avenel 2016-05-02 07:21:57 EDT
I do not think this is a bug. But I will capture this one part of Tenant Mapping and Impersonation trellos because we should improve it.
Comment 6 Greg Blomquist 2016-05-27 19:38:18 EDT
Based on feedback from Loic, closing this as not a bug.

Note You need to log in before you can comment on or make changes to this bug.