Bug 1276869 - [kernel] kvm[]: vcpu0/1 unhandled rdmsr: 0x570
[kernel] kvm[]: vcpu0/1 unhandled rdmsr: 0x570
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
23
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: fedora-kernel-kvm
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-31 14:26 EDT by Joachim Frieben
Modified: 2015-11-14 03:26 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-02 12:52:41 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Linux Kernel 102651 None None None Never

  None (edit)
Description Joachim Frieben 2015-10-31 14:26:09 EDT
Description of problem:
The system log produced by dmesg on a Fedora 23 system repeatedly contains entries:

    "kvm[]: vcpu0 unhandled rdmsr: 0x570
    "kvm[]: vcpu1 unhandled rdmsr: 0x570"

when running a virtual machine in gnome-boxes.

Version-Release number of selected component (if applicable):
kernel-4.2.3-300.fc23

How reproducible:
Always

Steps to Reproduce:
1. Run a virtual machine in gnome-boxes.

Actual results:
dmesg returns kvm messages about unhandled rdmsr.

Expected results:
No kvm messages about unhandled rdmsr.

Additional info:
None
Comment 1 Josh Boyer 2015-11-02 08:13:18 EST
Yes, we see this often.  It is informational.  Any changes need to be done upstream.
Comment 2 Joachim Frieben 2015-11-02 12:03:56 EST
This bug has already been reported upstream in bug https://bugzilla.kernel.org/show_bug.cgi?id=102651 but it has not been resolved yet.
Comment 3 Josh Boyer 2015-11-02 12:52:41 EST
As I said, this needs to be done upstream.  It turns out it already is with:

https://git.kernel.org/cgit/linux/kernel/git/next/linux-next.git/commit/arch/x86/kernel/cpu/perf_event_intel_pt.c?id=73fdeb66592ee80dffb16fb8a9b7378a00c1a826

That will be in the upcoming 4.4 kernel release.  Fedora will inherit that through its normal kernel update process.
Comment 4 Joachim Frieben 2015-11-14 03:26:33 EST
Related entries still appear for kernel-4.4.0-0.rc0.git9.1.fc24.

Note You need to log in before you can comment on or make changes to this bug.