Bug 1277014 - Multiple mouse clicks required on laptop
Multiple mouse clicks required on laptop
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-vmmouse (Show other bugs)
24
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-02 00:00 EST by Danny Ciarniello
Modified: 2016-07-17 23:15 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-17 23:15:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Danny Ciarniello 2015-11-02 00:00:07 EST
Description of problem:
I have Fedora 22 and KDE installed on an HP Envy dv7 laptop.  The problem that I have run into is that it requires 2 or more mouse clicks before the system responds to the clicks. 

This is not an application-specific problem but a system-wide problem as it affects anything requiring mouse clicks such as opening the application launcher from the taskbar, clicking on desktop items or clicking on links in a browser.

It is somewhat intermittent in that sometimes the mouse works just fine but for the most part it takes multiple clicks to get anything done.


Version-Release number of selected component (if applicable):


How reproducible: Almost always


Steps to Reproduce:
1. Install F22 and KDE on an HP Envy dv7 laptop
2. Click on something with the mouse
3.

Actual results:
Often takes 2 or more mouse clicks before system responds


Expected results:
System should respond on first mouse click


Additional info:
Not certain that I've picked the right component but it seems the most likely.

Not certain is this is a contributing factor but the system loads 2 display kernel drivers:
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
        DeviceName: Intel(R) HD Graphics 4000
        Subsystem: Hewlett-Packard Company Device 181d
        Kernel driver in use: i915
        Kernel modules: i915
01:00.0 VGA compatible controller: NVIDIA Corporation GF108M [GeForce GT 630M] (rev a1)
        DeviceName: NVIDIA GeForce GT 630M
        Subsystem: Hewlett-Packard Company Device 181d
        Kernel driver in use: nouveau
        Kernel modules: nouveau

This is probably hardware-specific as I have a desktop system (only 1 display kernel module) that does not exhibit this behaviour.
Comment 1 Danny Ciarniello 2016-07-17 02:19:38 EDT
This seemed to have gone away but the problem has returned.  I just upgraded the system to F24 and the problem still exists.

Would certainly be nice if somebody would look into it.
Comment 2 Danny Ciarniello 2016-07-17 02:45:54 EDT
Further information which I forgot to include with the original description:

The mouse that I'm using is a wireless USB mouse from Verbatim (Model 97262).  The laptop's touchpad seems to work fine.

The Logitech wireless USB mouse that I use on my desktop works flawlessly.
Comment 3 Peter Hutterer 2016-07-17 21:04:21 EDT
are you actually using vmware? the vmmouse component is the one used when you're running inside a vmware virtual machine.

If you're not using vmware, please run sudo evemu-record and select your mouse. Can you see all button events in the output? If button events are missing here then the issue is either in the kernel or -more likely- the HW itself.
Comment 4 Danny Ciarniello 2016-07-17 22:19:45 EDT
No, this isn't running inside a VM.

I've done a little more investigation the last couple of days and have decided that it isn't a software issue but a hardware one since I've now tried the Logitech wireless mouse from my desktop and it seems to work fine.  I was going to pick up a replacement for the Verbatim and try that to confirm before reporting back.
Comment 5 Peter Hutterer 2016-07-17 23:15:11 EDT
Ok, thanks. I'll close this bug for now if the new mouse does the same please re-open it. Thanks.

Note You need to log in before you can comment on or make changes to this bug.