Bug 127702 - procps: top Reports CPU Utilization above 100%
procps: top Reports CPU Utilization above 100%
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: procps (Show other bugs)
1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-12 14:44 EDT by Matt Siemens
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-20 12:46:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Top showing the problem. (40.49 KB, image/png)
2004-07-12 14:46 EDT, Matt Siemens
no flags Details

  None (edit)
Description Matt Siemens 2004-07-12 14:44:56 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7)
Gecko/20040626 Firefox/0.9.1

Description of problem:
When using top to monitor a system under heavy load (in my case, a
system undergoing stress testing), top will occasionally display an
idle value of 3624114749255314.0% or similar.  See the enclosed
screenshot for details.

SYSTEM DETAILS:
2 x 2.4 GHz Xeon CPUs with Hyperthreading enabled
1 GB RAM
Kernel 2.4.22-1.2194.nptl (SMP)

Version-Release number of selected component (if applicable):
procps-3.2.0-1.1

How reproducible:
Always

Steps to Reproduce:
Force your system to use all CPU time, and monitor the system with
top.  Within the first minute you should see the odd reading.
Comment 1 Matt Siemens 2004-07-12 14:46:29 EDT
Created attachment 101821 [details]
Top showing the problem.
Comment 2 Daniel Walsh 2004-07-20 11:24:09 EDT
Does procps-3.2.2-1 still show this behaviour?
Comment 3 Matt Siemens 2004-07-20 11:45:42 EDT
Where can I find a copy of procps-3.2.2-1 for FC1?
Comment 5 Matt Siemens 2004-07-20 12:45:34 EDT
I compiled and installed procps-3.2.2-1 for FC1, and ran the same
stress tests as before.  I wasn't able to reproduce the problem found
in the older version of top. It looks like this newer version of
procps fixes the bug in top.

Note You need to log in before you can comment on or make changes to this bug.