Bug 1277023 - openchange-2.3-5.fc23.x86_64 requires libsamba-debug-samba4.so(SAMBA_4.3.0RC4)(64bit)
openchange-2.3-5.fc23.x86_64 requires libsamba-debug-samba4.so(SAMBA_4.3.0RC4...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: openchange (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Milan Crha
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-02 00:27 EST by Chris Smart
Modified: 2016-01-12 03:02 EST (History)
6 users (show)

See Also:
Fixed In Version: openchange-2.3-6.fc23 openchange-2.3-8.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-12 03:02:21 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Smart 2015-11-02 00:27:25 EST
Description of problem:
openchange cannot be installed as it cannot find a matching libsamba-debug-samba4.so library.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot or build Fedora 23 Workstation live image
2. Try to install openchange

Actual results:
dnf fails with:
Error: package openchange-2.3-5.fc23.x86_64 requires libsamba-debug-samba4.so(SAMBA_4.3.0RC4)(64bit), but none of the providers can be installed

Expected results:
dnf should pull in matching samba-client-libs that provides the right library version.

Additional info:
Looks like we just need to rebuild openchange again against new samba.
Comment 1 Milan Crha 2015-11-02 02:16:01 EST
Thanks for a bug report. I usually receive "broken dependencies" email for such situation, but not this time. I do not know why. I received a similar recently, for the rawhide, but not for the Fedora 23. I'm rebuilding the package now. I'll file an update when it's done.
Comment 2 Fedora Update System 2015-11-02 02:37:34 EST
openchange-2.3-6.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-ab29c9168f
Comment 3 Chris Smart 2015-11-02 04:20:55 EST
I can't speak for the package itself but the dependencies are working. Thanks.
Comment 4 Fedora Update System 2015-11-02 19:24:46 EST
openchange-2.3-6.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update openchange'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-ab29c9168f
Comment 5 Fedora Update System 2015-11-13 17:55:31 EST
openchange-2.3-6.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 6 Trevin 2015-11-26 04:35:09 EST
Hi, similar problem repeated for me on Fedora 23:

package openchange-2.3-6.fc23.x86_64 requires libsamba-debug-samba4.so(SAMBA_4.3.0)(64bit), but none of the providers can be installed.
Comment 7 Artem Tuchinsky 2015-11-26 04:40:18 EST
I confirm, fedora 23 has this problem

[artem@chidori ~]$ cat /etc/fedora-release 
Fedora release 23 (Twenty Three)

[artem@chidori ~]$ sudo dnf update --best --allowerasing
Last metadata expiration check performed 0:00:31 ago on Thu Nov 26 13:39:30 2015.
Ошибка: package openchange-2.3-6.fc23.x86_64 requires libsamba-debug-samba4.so(SAMBA_4.3.0)(64bit), but none of the providers can be installed.
package openchange-2.3-6.fc23.x86_64 requires libsamba-debug-samba4.so(SAMBA_4.3.0)(64bit), but none of the providers can be installed
Comment 8 Milan Crha 2015-11-26 05:51:16 EST
It's because the samba package updated again, and again didn't rebuild OpenChange together with it. It'll be a never ending story as long as:
a) samba folks will not build OpenChange together with samba update
b) newer openchange is not released, which doesn't depend on the samba-debug
   library explicitly.
Comment 9 Fedora Update System 2015-11-26 06:29:52 EST
openchange-2.3-7.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-b273e4a581
Comment 10 Fedora Update System 2015-11-26 18:49:51 EST
openchange-2.3-7.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update openchange'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-b273e4a581
Comment 11 Andrew Meredith 2015-12-08 05:22:27 EST
openchange-2.3-7.fc23.x86_64 installed alongside samba-4.3.1-3.fc23.x86_64 and all looks well.
Comment 12 Fedora Update System 2015-12-08 11:42:27 EST
openchange-2.3-8.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-b273e4a581
Comment 13 Fedora Update System 2015-12-08 17:58:46 EST
openchange-2.3-8.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update openchange'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-b273e4a581
Comment 14 Artem Tuchinsky 2015-12-18 05:47:59 EST
it happens again

[artem@chidori ~]$ LANG=C sudo dnf update --best --allowerasing
Last metadata expiration check performed 0:03:07 ago on Fri Dec 18 14:44:24 2015.
Error: package openchange-2.3-7.fc23.x86_64 requires libsamba-debug-samba4.so(SAMBA_4.3.1)(64bit), but none of the providers can be installed.
nothing provides libsamba-debug-samba4.so(SAMBA_4.3.0)(64bit) needed by openchange-2.3-6.fc23.x86_64
Comment 15 Chris Smart 2015-12-18 18:13:12 EST
I don't think this is scalable, we need a better way to handle this. It keeps happening too often..
Comment 16 Artem Tuchinsky 2016-01-11 05:26:57 EST
What is now the solution?
Comment 17 Milan Crha 2016-01-11 09:15:27 EST
I marked openchange-2.3-8.fc23 as a stable update, which contains a better fix (with respect of the dependency issues to samba-debug library. It doesn't reference it at all, thus the samba package can be updated without breaking openchange on this samba private library. I suppose bodhi will update this bug report shortly after it pushes the latest update to the stable repositories.
Comment 18 Fedora Update System 2016-01-12 03:02:16 EST
openchange-2.3-8.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.