Bug 1277067 - perl-Catalyst-Authentication-Credential-HTTP-1.016-3.fc24 FTBFS: t/live_app.t test fails
perl-Catalyst-Authentication-Credential-HTTP-1.016-3.fc24 FTBFS: t/live_app.t...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: perl-Catalyst-Authentication-Credential-HTTP (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Emmanuel Seyman
Fedora Extras Quality Assurance
http://koji.fedoraproject.org/koji/ta...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-02 04:07 EST by Petr Pisar
Modified: 2015-11-15 06:41 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-15 06:41:48 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
CPAN 108597 None None None Never

  None (edit)
Description Petr Pisar 2015-11-02 04:07:36 EST
perl-Catalyst-Authentication-Credential-HTTP-1.016-3.fc24 fails to build in F24 because a test fails:

t/basic.t ................... ok
[error] Caught exception in AuthTestApp::Controller::Root->moose "Can't call method "id" on an undefined value at /builddir/build/BUILD/Catalyst-Authentication-Credential-HTTP-1.016/t/lib/AuthTestApp/Controller/Root.pm line 15."
#   Failed test 'status is 401'
#   at t/live_app.t line 24.
#          got: '500'
#     expected: '401'
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
    "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
<head>
    <meta http-equiv="Content-Language" content="en" />
    <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
    <title>AuthTestApp</title>
    <script type="text/javascript">
        <!--
        function toggleDump (dumpElement) {
            var e = document.getElementById( dumpElement );
            if (e.style.display == "none") {
                e.style.display = "";
            }
            else {
                e.style.display = "none";
            }
        }
        -->
    </script>
    <style type="text/css">
        body {
            font-family: "Bitstream Vera Sans", "Trebuchet MS", Verdana,
                         Tahoma, Arial, helvetica, sans-serif;
            color: #333;
            background-color: #eee;
            margin: 0px;
            padding: 0px;
        }
        :link, :link:hover, :visited, :visited:hover {
            color: #000;
        }
        div.box {
            position: relative;
            background-color: #ccc;
            border: 1px solid #aaa;
            padding: 4px;
            margin: 10px;
        }
        div.error {
            background-color: #cce;
            border: 1px solid #755;
            padding: 8px;
            margin: 4px;
            margin-bottom: 10px;
        }
        div.infos {
            background-color: #eee;
            border: 1px solid #575;
            padding: 8px;
            margin: 4px;
            margin-bottom: 10px;
        }
        div.name {
            background-color: #cce;
            border: 1px solid #557;
            padding: 8px;
            margin: 4px;
        }
        code.error {
            display: block;
            margin: 1em 0;
            overflow: auto;
        }
        div.name h1, div.error p {
            margin: 0;
        }
        h2 {
            margin-top: 0;
            margin-bottom: 10px;
            font-size: medium;
            font-weight: bold;
            text-decoration: underline;
        }
        h1 {
            font-size: medium;
            font-weight: normal;
        }
        /* from http://users.tkk.fi/~tkarvine/linux/doc/pre-wrap/pre-wrap-css3-mozilla-opera-ie.html */
        /* Browser specific (not valid) styles to make preformatted text wrap */
        pre {
            white-space: pre-wrap;       /* css-3 */
            white-space: -moz-pre-wrap;  /* Mozilla, since 1999 */
            white-space: -pre-wrap;      /* Opera 4-6 */
            white-space: -o-pre-wrap;    /* Opera 7 */
            word-wrap: break-word;       /* Internet Explorer 5.5+ */
        }
    </style>
</head>
<body>
    <div class="box">
        <div class="error"></div>
        <div class="infos"><pre>
(en) Please come back later
(fr) SVP veuillez revenir plus tard
(de) Bitte versuchen sie es spaeter nocheinmal
(at) Konnten's bitt'schoen spaeter nochmal reinschauen
(no) Vennligst prov igjen senere
(dk) Venligst prov igen senere
(pl) Prosze sprobowac pozniej
(pt) Por favor volte mais tarde
(ru) Попробуйте еще раз позже
(ua) Спробуйте ще раз пізніше
(it) Per favore riprova più tardi
</pre>
</div>
        <div class="name"></div>
    </div>
</body>
</html>
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                 at t/live_app.t line 24.
# Tests were run but no plan was declared and done_testing() was not seen.
# Looks like your test exited with 255 just after 1.
t/live_app.t ................ 
Dubious, test returned 255 (wstat 65280, 0xff00)
Failed 1/1 subtests 

Difference between working and failing build root is:

        perl-Catalyst-Runtime 	5.90101-1.fc24 	> 	5.90102-1.fc24
	nss-softokn-freebl 	3.20.0-2.fc24 	> 	3.20.1-1.fc24
	perl-CGI-Compile 	0.19-3.fc23 	> 	0.20-1.fc24
	nss-util 	3.20.0-2.fc24 	> 	3.20.1-1.fc24
	nss-tools 	3.20.0-6.fc24 	> 	3.20.1-2.fc24
	nss-softokn 	3.20.0-2.fc24 	> 	3.20.1-1.fc24
	nss 	3.20.0-6.fc24 	> 	3.20.1-2.fc24
	nss-sysinit 	3.20.0-6.fc24 	> 	3.20.1-2.fc24
Comment 1 Emmanuel Seyman 2015-11-15 06:41:48 EST
The test failure was due to a bug in perl-Catalyst-Runtime which was fixed in Catalyst-Runtime 5.90103.

This package now builds from source without issue.
http://koji.fedoraproject.org/koji/taskinfo?taskID=11847664

Note You need to log in before you can comment on or make changes to this bug.