Bug 1277078 - Register with subscription-manager failed with username and password [NEEDINFO]
Register with subscription-manager failed with username and password
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node (Show other bugs)
3.5.6
Unspecified Unspecified
urgent Severity urgent
: ovirt-3.5.6
: 3.5.6
Assigned To: Anatoly Litovsky
wanghui
node
: TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-02 04:39 EST by wanghui
Modified: 2016-02-10 14:18 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-03 00:40:21 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Node
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
fdeutsch: needinfo? (crog)


Attachments (Terms of Use)

  None (edit)
Description wanghui 2015-11-02 04:39:54 EST
Description of problem:
Register to RHN with username and password failed. It reports error like "An exception during the transaction: Organization must be specified with Satellite 6". 

Version-Release number of selected component (if applicable):
rhev-hypervisor7-7.2-20151029.0.el7ev
ovirt-node-3.2.3-26.el7.noarch
ovirt-node-plugin-rhn-3.2.3-26.el7.noarch

How reproducible:
100%

Steps to Reproduce:
1. Install rhev-hypervisor7-7.2-20151029.0.el7ev
2. Enable network
3. Register to RHN with username and password.

Actual results:
1. After step3, it reports error like follows.
"An exception during the transaction: Organization must be specified with Satellite 6"

/var/log/ovirt-node.log

2015-11-02 06:02:11,276    WARNING File "/etc/rhsm/rhsm.conf" had already been persisted
2015-11-02 06:02:11,277       INFO Registering to RHN account.....
2015-11-02 06:02:11,278       INFO ['/usr/sbin/subscription-manager', 'register', '--username', 'qa@redhat.com', '--password', 'XXXXXXX', '--force']
2015-11-02 06:02:18,729       INFO Captured nothing
2015-11-02 06:02:18,729       INFO An exception during the transaction: Organization must be specified with Satellite 6
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/ovirt/node/ui/__init__.py", line 949, in __run_transaction
  File "/usr/lib/python2.7/site-packages/ovirt/node/plugins.py", line 188, in dry_or
  File "/usr/lib/python2.7/site-packages/ovirt/node/ui/__init__.py", line 949, in <lambda>
  File "/usr/lib/python2.7/site-packages/ovirt/node/setup/rhn/rhn_model.py", line 380, in commit
RuntimeError: Organization must be specified with Satellite 6

Expected results:
1. It should register to RHN succeed.

Additional info:
Comment 4 Fabian Deutsch 2015-11-02 08:26:39 EST
Chris, can you tell if the cli argument requirements of subscription-manager changed lately?
Comment 7 Fabian Deutsch 2015-11-03 02:13:46 EST
The issue was caused by a password change of the account used for testing.

But the error message we saw in the description does not reflect this. This could be improved.

Note You need to log in before you can comment on or make changes to this bug.