Bug 1277113 - grep-2.22 is available
grep-2.22 is available
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: grep (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jaroslav Škarvada
Fedora Extras Quality Assurance
: FutureFeature, Reopened, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-02 07:13 EST by Upstream Release Monitoring
Modified: 2015-11-05 17:23 EST (History)
3 users (show)

See Also:
Fixed In Version: grep-2.22-1.fc23
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-05 17:23:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
[patch] Update to 2.22 (#1277113) (965 bytes, patch)
2015-11-02 07:13 EST, Upstream Release Monitoring
no flags Details | Diff

  None (edit)
Description Upstream Release Monitoring 2015-11-02 07:13:14 EST
Latest upstream release: 2.22
Current version/release in rawhide: 2.21-7.fc24
URL: http://www.gnu.org/software/grep/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.
Comment 1 Upstream Release Monitoring 2015-11-02 07:13:37 EST
Created attachment 1088546 [details]
[patch] Update to 2.22 (#1277113)
Comment 2 Upstream Release Monitoring 2015-11-02 07:15:15 EST
Scratch build failed http://koji.fedoraproject.org/koji/taskinfo?taskID=11671257
Comment 3 Jaroslav Škarvada 2015-11-02 13:26:36 EST
Reopening, some tests started segfaulting on rawhide in koji, currently I am unable to reproduce this locally. I will look on it.
Comment 4 Account closed by the user 2015-11-02 16:02:12 EST
(In reply to Jaroslav Škarvada from comment #3)

> Reopening, some tests started segfaulting on rawhide in koji, currently I am
> unable to reproduce this locally. I will look on it.

Trying to build grep-2.22-1.fc23.src.rpm in Fedora 23.
It builds OK, but dmesg shows:

[10663.926599] grep[27708]: segfault at 0 ip 00007f4a955789f9 sp 00007ffd395ec4f0 error 4 in libc-2.22.so[7f4a95559000+1b7000]
[10670.348920] traps: grep[7050] general protection ip:7f03ac6d89f9 sp:7ffe064ced40 error:0 in libc-2.22.so[7f03ac6b9000+1b7000]
Comment 5 Upstream Release Monitoring 2015-11-04 10:44:18 EST
jskarvad's grep-2.22-1.fc24 completed http://koji.fedoraproject.org/koji/buildinfo?buildID=695595
Comment 6 Fedora Update System 2015-11-04 12:45:06 EST
grep-2.22-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-6a6fc44d72
Comment 7 Fedora Update System 2015-11-04 20:27:31 EST
grep-2.22-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update grep'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-6a6fc44d72
Comment 8 Upstream Release Monitoring 2015-11-05 08:49:03 EST
jskarvad's grep-2.22-2.fc24 completed http://koji.fedoraproject.org/koji/buildinfo?buildID=696215
Comment 9 Fedora Update System 2015-11-05 17:23:52 EST
grep-2.22-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.