Bug 1277153 - [RFE] Support All (supported) Java as a JVM vendor for Java Based images/cartridges
[RFE] Support All (supported) Java as a JVM vendor for Java Based images/cart...
Status: CLOSED DEFERRED
Product: OpenShift Container Platform
Classification: Red Hat
Component: RFE (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: kconner
Johnny Liu
:
: 1251957 (view as bug list)
Depends On:
Blocks: 1267746 1277163
  Show dependency treegraph
 
Reported: 2015-11-02 08:50 EST by Eric Rich
Modified: 2016-11-25 04:01 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1277163 (view as bug list)
Environment:
Last Closed: 2016-07-18 13:19:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker CLOUD-680 Minor Reopened Document how to add alternative JVM options in the EAP / JWS / XPaaS images 2018-04-04 05:25 EDT
Red Hat Bugzilla 1252306 None CLOSED [RFE] provide Oracle Java container base image 2018-04-04 05:25 EDT

  None (edit)
Description Eric Rich 2015-11-02 08:50:24 EST
Description of problem:

EAP and JWS both support multiple JVM vendors. See: 

    https://access.redhat.com/articles/111663
    https://access.redhat.com/articles/1377603

The provided JVM vendors should be available to customers so that they can choose the JVM/JDK that works with there application. 

RHEL Ships a variety of option (only OpenJDK is supported): 

    OpenJDK: https://access.redhat.com/articles/1299013
      Other: https://access.redhat.com/solutions/732883

  OpenJDK: https://access.redhat.com/downloads/content/rhel---7/x86_64/2456/java-1.8.0-openjdk/1.8.0.65-2.b17.el7_1/x86_64/fd431d51/package   
      IBM: https://access.redhat.com/downloads/content/rhel---7/x86_64/2476/java-1.7.1-ibm/1.7.1.3.10-1jpp.1.el7_1/x86_64/fd431d51/package
   Oracle:
Comment 4 Eric Rich 2016-05-17 14:40:09 EDT
*** Bug 1251957 has been marked as a duplicate of this bug. ***
Comment 6 JBoss JIRA Server 2016-09-30 14:22:34 EDT
Rob Cernich <rcernich@redhat.com> updated the status of jira CLOUD-680 to Closed

Note You need to log in before you can comment on or make changes to this bug.