Bug 1277218 - Swift ring is configured with controller even if swift on controllers is deactivate [NEEDINFO]
Swift ring is configured with controller even if swift on controllers is deac...
Status: CLOSED DEFERRED
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
high Severity high
: ---
: 9.0 (Mitaka)
Assigned To: Christian Schwede (cschwede)
Shai Revivo
: Triaged, ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-02 12:18 EST by Pierre Blanc
Modified: 2017-08-18 11:38 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-18 11:38:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
pgrist: needinfo? (pblanc)


Attachments (Terms of Use)

  None (edit)
Description Pierre Blanc 2015-11-02 12:18:46 EST
Description of problem:
Even if you deactivate swift on controllers the ring is configured with

Version-Release number of selected component (if applicable):
7.0

How reproducible:
Deploy a new stack with object-storage nodes and set ControllerEnableSwiftStorage to false on your deployment file environment.

Actual results:
After a deployment, the swift ring contain reference to controllers 
$ sudo swift-ring-builder /etc/swift/object.ring.gz | grep d1
             9       1     1    x.x.x.x  6000    x.x.x.x              6000        d1 100.00         79    0.29 
            26       1     1    x.x.x.x  6000    x.x.x.x              6000        d1 100.00         79    0.29 
            33       1     1    x.x.x.x  6000    x.x.x.x              6000        d1 100.00         79    0.29 

Expected results:
No reference to controllers on swift ring
Comment 2 Mike Burns 2016-04-07 16:54:03 EDT
This bug did not make the OSP 8.0 release.  It is being deferred to OSP 10.
Comment 4 Paul Grist 2016-10-13 20:29:32 EDT
Moving this to the list to review for the next release. It may actually be a duplicate of one of the deployment cleanups or fixes in progress.
Comment 5 Elise Gafford 2016-11-30 09:56:39 EST
Because of composable roles framework, this bug no longer applies to RHOS 10 or RHOS 11; resetting to 9.0.z; requires backports to 8.0.z and 7.0.z.
Comment 6 Paul Grist 2017-08-18 11:38:40 EDT
Hi Pierre,  I think this has been improved quite a bit in more recent releases.  I'm going to close this one out.  Please re-open if you have a customer case that needs this support in older releases.  Thanks.

Note You need to log in before you can comment on or make changes to this bug.