Bug 1277242 - [abrt] totem: object_heap_destroy(): totem killed by SIGFPE
[abrt] totem: object_heap_destroy(): totem killed by SIGFPE
Status: CLOSED DUPLICATE of bug 1286365
Product: Fedora
Classification: Fedora
Component: totem (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:9c5229dcb42762a8c96b5e75f26...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-02 14:23 EST by Dark Shenada
Modified: 2016-09-21 11:07 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-21 11:07:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (69.32 KB, text/plain)
2015-11-02 14:23 EST, Dark Shenada
no flags Details
File: cgroup (190 bytes, text/plain)
2015-11-02 14:23 EST, Dark Shenada
no flags Details
File: core_backtrace (47.12 KB, text/plain)
2015-11-02 14:23 EST, Dark Shenada
no flags Details
File: dso_list (21.87 KB, text/plain)
2015-11-02 14:24 EST, Dark Shenada
no flags Details
File: environ (3.42 KB, text/plain)
2015-11-02 14:24 EST, Dark Shenada
no flags Details
File: limits (1.29 KB, text/plain)
2015-11-02 14:24 EST, Dark Shenada
no flags Details
File: maps (96.11 KB, text/plain)
2015-11-02 14:24 EST, Dark Shenada
no flags Details
File: mountinfo (3.46 KB, text/plain)
2015-11-02 14:24 EST, Dark Shenada
no flags Details
File: open_fds (2.38 KB, text/plain)
2015-11-02 14:24 EST, Dark Shenada
no flags Details
File: proc_pid_status (1.01 KB, text/plain)
2015-11-02 14:24 EST, Dark Shenada
no flags Details
Video file that causes the crash for me (11.83 MB, application/octet-stream)
2015-11-08 13:07 EST, code
no flags Details

  None (edit)
Description Dark Shenada 2015-11-02 14:23:50 EST
Version-Release number of selected component:
totem-3.18.1-1.fc23

Additional info:
reporter:       libreport-2.6.3
backtrace_rating: 4
cmdline:        totem 151026rio-HD.wmv
crash_function: object_heap_destroy
executable:     /usr/bin/totem
global_pid:     4623
kernel:         4.2.3-300.fc23.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 object_heap_destroy at object_heap.c:275
 #1 destroy_heap at vdpau_driver.c:138
 #3 vdpau_common_Terminate at vdpau_driver.c:159
 #4 vdpau_Terminate_Current at vdpau_driver_template.h:537
 #5 vdpau_Initialize_Current at vdpau_driver_template.h:563
 #6 __vaDriverInit_0_38 at vdpau_driver.c:317
 #7 va_openDriver at va.c:296
 #8 vaInitialize at va.c:559
 #9 gst_vaapi_display_create_unlocked at gstvaapidisplay.c:937
 #10 gst_vaapi_display_create at gstvaapidisplay.c:968

Potential duplicate: bug 1176187
Comment 1 Dark Shenada 2015-11-02 14:23:55 EST
Created attachment 1088698 [details]
File: backtrace
Comment 2 Dark Shenada 2015-11-02 14:23:56 EST
Created attachment 1088699 [details]
File: cgroup
Comment 3 Dark Shenada 2015-11-02 14:23:58 EST
Created attachment 1088700 [details]
File: core_backtrace
Comment 4 Dark Shenada 2015-11-02 14:24:00 EST
Created attachment 1088701 [details]
File: dso_list
Comment 5 Dark Shenada 2015-11-02 14:24:02 EST
Created attachment 1088702 [details]
File: environ
Comment 6 Dark Shenada 2015-11-02 14:24:03 EST
Created attachment 1088703 [details]
File: limits
Comment 7 Dark Shenada 2015-11-02 14:24:05 EST
Created attachment 1088704 [details]
File: maps
Comment 8 Dark Shenada 2015-11-02 14:24:07 EST
Created attachment 1088705 [details]
File: mountinfo
Comment 9 Dark Shenada 2015-11-02 14:24:08 EST
Created attachment 1088706 [details]
File: open_fds
Comment 10 Dark Shenada 2015-11-02 14:24:10 EST
Created attachment 1088707 [details]
File: proc_pid_status
Comment 11 code 2015-11-08 12:47:38 EST
Another user experienced a similar problem:

Attempt to open a particular video.

reporter:       libreport-2.6.3
backtrace_rating: 4
cmdline:        /usr/bin/totem --gapplication-service
crash_function: object_heap_destroy
executable:     /usr/bin/totem
global_pid:     30360
kernel:         4.2.5-300.fc23.x86_64
package:        totem-3.18.1-1.fc23
reason:         totem killed by SIGFPE
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 12 code 2015-11-08 12:57:16 EST
This appears to be triggered by a particular video file. The same file crashes Shotwell on startup simply by being in the library (#1279220). I don’t know enough about the relevant libraries to know exactly which component this should really be filed against. The video plays fine in mplayer.
Comment 13 code 2015-11-08 13:07 EST
Created attachment 1091335 [details]
Video file that causes the crash for me
Comment 14 code 2015-11-08 13:12:30 EST
It’s not just the one video file. Many others cause a similar crash.
Comment 15 code 2015-11-28 11:08:33 EST
Potential duplicate: bug 1286365

It appears libva may be the real problem here.
Comment 16 Bastien Nocera 2016-09-21 11:07:19 EDT
(In reply to code from comment #15)
> Potential duplicate: bug 1286365
> 
> It appears libva may be the real problem here.

Indeed, thanks.

*** This bug has been marked as a duplicate of bug 1286365 ***

Note You need to log in before you can comment on or make changes to this bug.