This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1277243 - undefined method `description' for nil:NilClass [vm_infra/x_show]
undefined method `description' for nil:NilClass [vm_infra/x_show]
Status: CLOSED CURRENTRELEASE
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Replication (Show other bugs)
5.5.0
Unspecified Unspecified
high Severity high
: GA
: 5.5.0
Assigned To: Joe Rafaniello
Dave Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-02 14:24 EST by Alex Newman
Modified: 2015-11-19 12:15 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 12:15:59 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 Joe Rafaniello 2015-11-17 10:39:41 EST
Alex, do you have the production.log for this error?  The UI code is blowing up and the logs your provided do not have the undefined method `description' for nil:NilClass error.

I'll try to recreate the issue but if you have the production.log, we're more likely to see what exactly is failing.
Comment 3 Joe Rafaniello 2015-11-17 11:44:15 EST
Alex, please provide the production.log and exact steps to reproduce.  It's not clear to me which steps are done on the master/slave (parent/child) appliance and when.  For example, it looks like you're getting this exception raised when browsing on the master or parent region where the slave/child is replicating to but it's not entirely clear what steps happen where.

From the information provided, I'm guessing the exception might be occurring here:

https://github.com/ManageIQ/manageiq/blob/3182e251973612b5fa1763c4f67da37322834200/app/helpers/vm_infra_helper/textual_summary.rb#L79

Or
https://github.com/ManageIQ/manageiq/blob/3182e251973612b5fa1763c4f67da37322834200/app/helpers/vm_infra_helper/textual_summary.rb#L81

Or
https://github.com/ManageIQ/manageiq/blob/3182e251973612b5fa1763c4f67da37322834200/app/helpers/vm_infra_helper/textual_summary.rb#L95

If it's one of these, the problem is that the Vm does not have an associated miq_regions.  If this is the case, maybe you're excluding the miq_regions table, see exclude_tables section of the "advanced" tab in the configuration, or you happened to catch it after the vms table was replicated but before the miq_regions table was replicated.  If you can recreate this, please confirm the contents of the vms table and miq_regions table... specifically, the id of the vms table you hit the error on and the contents of the miq_regions table.  Again, I'd assume the problem is on the master/parent region database, where the slave/child is replicating to.

Please recreate the issue, provide the logs (both evm.log and production.log from both appliances), steps on each appliance to setup, if replication was started and completed, etc.

Thank you.
Comment 4 Alex Newman 2015-11-19 12:15:59 EST
Unable to reproduce in 5.5.0.11-rc1.20151117182049_653c0d4

Note You need to log in before you can comment on or make changes to this bug.