Bug 1277281 - nss requires nss-util which requires nss-util.i686 which requires glibc.i686 which can't load
nss requires nss-util which requires nss-util.i686 which requires glibc.i686 ...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: nss (Show other bugs)
24
x86_64 Unspecified
unspecified Severity high
: ---
: ---
Assigned To: nss-nspr-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-02 17:39 EST by Peter Trenholme
Modified: 2017-06-28 11:46 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-28 11:46:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Trenholme 2015-11-02 17:39:02 EST
Description of problem: nss depends on a broken install of glibc.i686

Note: the glibc problem has (IIRC) been reported.

Version-Release number of selected component (if applicable): 3.20.1-2.fc24

How reproducible: Every time

Steps to Reproduce: dnf install nss

Actual results:
Error: Transaction check error:
  file /usr/share/doc/glibc/INSTALL from install of glibc-2.22.90-13.fc24.i686 conflicts with file from package glibc-2.22.90-11.fc24.x86_64
  file /usr/share/doc/glibc/NEWS from install of glibc-2.22.90-13.fc24.i686 conflicts with file from package glibc-2.22.90-11.fc24.x86_64

Expected results: No errors

Additional info: I'm not sure why the glibc INSTALL and NEWS files are configured  to be incompatible in the i686 and x86_64 library versions, but I suspect that they are identical files in the same directory (.../doc/glibc/), and that either appending a i686 and x86_64 to those names, or removing the dependency (Why is it there?) would be a simple solution.
Comment 1 Peter Trenholme 2015-11-02 17:58:48 EST
As an experiment, I renamed the INSTALL and README files in .../doc/glibc/ with an .x86_64 suffix, and then ran a "dnf update nss," which finished with no error messages, and (interestingly enough) no install of glibc.i686. So I did a

# dnf info installed glibc
and got this:

Last metadata expiration check performed 0:54:45 ago on Mon Nov  2 13:54:36 2015.
Installed Packages
Name        : glibc
Arch        : i686
Epoch       : 0
Version     : 2.22.90
Release     : 11.fc24
...
Name        : glibc
Arch        : x86_64
Epoch       : 0
Version     : 2.22.90
Release     : 11.fc24
...

So, clearly, I already had both glibc arch. versions installed, and so I wonder if this bug should be against dnf, not nss? Apparently the check is using more of the package info than it needs to use . . .
Comment 2 Jan Kurik 2016-02-24 10:31:43 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 3 Fedora Admin XMLRPC Client 2016-08-15 11:53:24 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 4 Kai Engert (:kaie) 2017-06-28 11:46:04 EDT
Sorry that this bug didn't get any attention, but now two years later, I'm not aware of problems to install nss.x86_64 and nss.i686 at the same time, it works for me in f25. Closing. Please reopen if you still see the problem.

Note You need to log in before you can comment on or make changes to this bug.