Bug 127729 - rpmbuild --target=... --showrc does not evalute the --target=
rpmbuild --target=... --showrc does not evalute the --target=
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
Mike McLean
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-12 19:22 EDT by Mark Hatle
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-05 12:29:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch that makes --target= apply before the --showrc in rpmbuild (3.70 KB, patch)
2004-07-12 19:24 EDT, Mark Hatle
no flags Details | Diff
Revised patch to support --showrc and --eval when --target= is used in rpmbuild (3.73 KB, patch)
2004-07-29 14:11 EDT, Mark Hatle
no flags Details | Diff

  None (edit)
Description Mark Hatle 2004-07-12 19:22:50 EDT
Description of problem:
When using rpmbuild --target=<target> --showrc, the output shows what
the rpm macros would be without specifying --target=.

I believe it makes more sense to evaluate the --target= parameter.

Version-Release number of selected component (if applicable):
all

How reproducible:
rpmbuild --showrc > output1
rpmbuild --target=i386-linux --showrc > output2
diff output1 output2

Actual results:
Same..

Expected results:
Different based on per arch macros

Additional info:
I will be attaching a patch we have used to solve this issue since RPM
4.1.  It has been HEAVILY tested.
Comment 1 Mark Hatle 2004-07-12 19:24:53 EDT
Created attachment 101842 [details]
Patch that makes --target= apply before the --showrc in rpmbuild

This patch has been applied and tested with MontaVista Linux since RPM 4.1.  It
seems to "work for us".
Comment 2 Mark Hatle 2004-07-29 14:09:42 EDT
Comment on attachment 101842 [details]
Patch that makes --target= apply before the --showrc in rpmbuild

slight change to allow --eval to work.
Comment 3 Mark Hatle 2004-07-29 14:11:28 EDT
Created attachment 102291 [details]
Revised patch to support --showrc and --eval when --target= is used in rpmbuild

Revised patch.	Supports both --eval and --showrc operations to rpmbuild when
--target= is selected.
Comment 4 Jeff Johnson 2004-10-17 15:01:10 EDT
This is almost correct, but does not handle
multiple platforms after --target. Purty easy
to just use the first target for --showrc
instead.
Comment 5 David Juran 2005-10-08 13:42:25 EDT
This is still the case in rpm-4.4.1-22 in FC4
Comment 6 Jeff Johnson 2006-08-05 12:29:29 EDT
A slightly modified patch has been added to rpm cvs, will be in rpm-4.4.7 when released.

Note You need to log in before you can comment on or make changes to this bug.