Bug 127730 - rpmbuild needs to free the Rpmrc in some cases
Summary: rpmbuild needs to free the Rpmrc in some cases
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-07-12 23:33 UTC by Mark Hatle
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-17 18:57:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to add the two required rpmFreeRpmrc() calls. (771 bytes, patch)
2004-07-12 23:35 UTC, Mark Hatle
no flags Details | Diff

Description Mark Hatle 2004-07-12 23:33:43 UTC
Description of problem:
If the rpmrc contains macros that point to the target specific
directories, they are not always reread properly.

Version-Release number of selected component (if applicable):
all

Comment 1 Mark Hatle 2004-07-12 23:35:08 UTC
Created attachment 101843 [details]
Patch to add the two required rpmFreeRpmrc() calls.

This is what we have used in MontaVista Linux since rpm version 4.1.

Comment 2 Jeff Johnson 2004-10-17 18:57:10 UTC
Added to rpm CVS HEAD, should be in rpm-4.4 when built.
Thanks for the patch.


Note You need to log in before you can comment on or make changes to this bug.