Bug 1277324 - Satellite needs to provide a newer version of libdb
Satellite needs to provide a newer version of libdb
Status: CLOSED DUPLICATE of bug 1266232
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Installer (Show other bugs)
6.1.3
Unspecified Unspecified
unspecified Severity urgent (vote)
: 6.1.4
: --
Assigned To: Katello Bug Bin
Katello QA List
: Triaged
: 1277604 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-02 22:38 EST by Og Maciel
Modified: 2017-02-23 14:41 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-11 09:55:35 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Og Maciel 2015-11-02 22:38:19 EST
Description of problem:

Installing Satellite 6.1.3 on a RHEL 7.2 system fails with a dependency on libdb:

--> Processing Dependency: libdb(x86-64) = 5.3.21-17.el7_0.1 for package: libdb-cxx-5.3.21-17.el7_0.1.x86_64
---> Package maven-artifact-resolver.noarch 1:1.0-10.el7 will be installed
---> Package maven-common-artifact-filters.noarch 0:1.4-11.el7 will be installed
---> Package maven-filtering.noarch 0:1.1-3.el7 will be installed
---> Package maven-monitor.noarch 0:2.2.1-47.el7 will be installed
---> Package plexus-resources.noarch 0:1.0-0.15.a7.el7 will be installed
---> Package plexus-velocity.noarch 0:1.1.8-16.el7 will be installed
--> Finished Dependency Resolution
Error: Package: libdb-cxx-5.3.21-17.el7_0.1.x86_64 (rhel-7-server-satellite-6.1-rpms)
Requires: libdb(x86-64) = 5.3.21-17.el7_0.1
Installed: libdb-5.3.21-19.el7.x86_64 (@beaker-Server/7.2)
libdb(x86-64) = 5.3.21-19.el7
Available: libdb-5.3.21-17.el7.x86_64 (rhel-7-server-rpms)
libdb(x86-64) = 5.3.21-17.el7
Available: libdb-5.3.21-17.el7_0.1.x86_64 (rhel-7-server-rpms)
libdb(x86-64) = 5.3.21-17.el7_0.1
**********************************************************************
yum can be configured to try to resolve such errors by temporarily enabling
disabled repos and searching for missing dependencies.
To enable this functionality please set 'notify_only=0' in /etc/yum/pluginconf.d/search-disabled-repos.conf
**********************************************************************

Error: Package: libdb-cxx-5.3.21-17.el7_0.1.x86_64 (rhel-7-server-satellite-6.1-rpms)
Requires: libdb(x86-64) = 5.3.21-17.el7_0.1
Installed: libdb-5.3.21-19.el7.x86_64 (@beaker-Server/7.2)
libdb(x86-64) = 5.3.21-19.el7
Available: libdb-5.3.21-17.el7.x86_64 (rhel-7-server-rpms)
libdb(x86-64) = 5.3.21-17.el7
Available: libdb-5.3.21-17.el7_0.1.x86_64 (rhel-7-server-rpms)
libdb(x86-64) = 5.3.21-17.el7_0.1
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest


Version-Release number of selected component (if applicable):

* "RHEL-7.2-20151030.n.1 Server x86_64" box from beaker and a custom repo
* Satellite 6.1.3 from CDN

How reproducible:


Steps to Reproduce:
1. Obtain a "RHEL-7.2-20151030.n.1 Server x86_64" box from beaker and a custom repo pointing to its internal repository
2. Install Satellite 6.1.3 from CDN
3.

Actual results:

Dependency issue

Expected results:


Additional info:
Comment 1 Og Maciel 2015-11-02 22:39:31 EST
Workaround:

yum downgrade libdb libdb-utils
Comment 3 Lukas Pramuk 2015-11-03 11:51:52 EST
*** Bug 1277604 has been marked as a duplicate of this bug. ***
Comment 4 Corey Welton 2015-11-11 09:55:35 EST
Closing this as a dupe of bug #1266232

*** This bug has been marked as a duplicate of bug 1266232 ***

Note You need to log in before you can comment on or make changes to this bug.