Bug 1277355 - Win2012 got the error "DPC_WATCHDOG_VIOLATION"(bsod) [NEEDINFO]
Win2012 got the error "DPC_WATCHDOG_VIOLATION"(bsod)
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Vadim Rozenfeld
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-03 01:47 EST by Yang Meng
Modified: 2017-01-03 02:42 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-01-03 02:42:32 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
vrozenfe: needinfo? (meyang)


Attachments (Terms of Use)
screenshot (20.74 KB, image/jpeg)
2015-11-03 01:47 EST, Yang Meng
no flags Details
debug.tar.gz-RHEL7.1z_host (486.39 KB, application/x-gzip)
2015-11-17 02:51 EST, Gu Nini
no flags Details
pagefile.sys.tar.gz (3.98 MB, application/x-gzip)
2015-11-17 02:59 EST, Gu Nini
no flags Details

  None (edit)
Description Yang Meng 2015-11-03 01:47:39 EST
Created attachment 1088812 [details]
screenshot

Description of problem:
windows 2012r2 got bsod with error "CLOCK WATCHDOG TIMEOUT" when boot it up

Version-Release number of selected component (if applicable):
qemu-kvm-rhev-2.3.0-31.el7.x86_64
kernel-3.10.0-327.el7.x86_64

How reproducible:
i only met it once,i am tring to reproduce it now.

Steps to Reproduce:
1.boot up the guest with commandline:
/usr/libexec/qemu-kvm \
    -S  \
    -name 'virt-tests-vm1'  \
    -sandbox off  \
    -machine pc  \
    -nodefaults  \
    -vga qxl  \
    -chardev socket,id=qmp_id_qmpmonitor1,path=/tmp/monitor-qmpmonitor1-20151102-192931-9QB9hg6m,server,nowait \
    -mon chardev=qmp_id_qmpmonitor1,mode=control  \
    -chardev socket,id=qmp_id_catch_monitor,path=/tmp/monitor-catch_monitor-20151102-192931-9QB9hg6m,server,nowait \
    -mon chardev=qmp_id_catch_monitor,mode=control \
    -device pvpanic,ioport=0x505,id=iddzAEHp  \
    -chardev socket,id=serial_id_serial0,path=/tmp/serial-serial0-20151102-192931-9QB9hg6m,server,nowait \
    -device isa-serial,chardev=serial_id_serial0  \
    -chardev socket,id=seabioslog_id_20151102-192931-9QB9hg6m,path=/tmp/seabios-20151102-192931-9QB9hg6m,server,nowait \
    -device isa-debugcon,chardev=seabioslog_id_20151102-192931-9QB9hg6m,iobase=0x402 \
    -device ich9-usb-ehci1,id=usb1,addr=1d.7,multifunction=on,bus=pci.0 \
    -device ich9-usb-uhci1,id=usb1.0,multifunction=on,masterbus=usb1.0,addr=1d.0,firstport=0,bus=pci.0 \
    -device ich9-usb-uhci2,id=usb1.1,multifunction=on,masterbus=usb1.0,addr=1d.2,firstport=2,bus=pci.0 \
    -device ich9-usb-uhci3,id=usb1.2,multifunction=on,masterbus=usb1.0,addr=1d.4,firstport=4,bus=pci.0 \
    -drive id=drive_image1,if=none,cache=none,snapshot=on,aio=native,format=qcow2,file=/home/autotest/client/tests/virt/shared/data/images/win2012-64r2-virtio.qcow2 \
    -device virtio-blk-pci,id=image1,drive=drive_image1,bootindex=0,bus=pci.0,addr=03,disable-legacy=off,disable-modern=on \
    -device virtio-net-pci,mac=9a:62:63:64:65:66,id=idbZCWZ3,vectors=4,netdev=idSymyWz,bus=pci.0,addr=04,disable-legacy=off,disable-modern=on  \
    -netdev tap,id=idSymyWz,vhost=on,vhostfd=23,fd=22  \
    -m 8192  \
    -smp 8,maxcpus=8,cores=4,threads=1,sockets=2  \
    -cpu 'Opteron_G4',+kvm_pv_unhalt,hv_spinlocks=0x1fff,hv_vapic,hv_time \
    -drive id=drive_cd1,if=none,snapshot=on,aio=native,media=cdrom,file=/home/autotest/client/tests/virt/shared/data/isos/windows/winutils.iso \
    -device ide-cd,id=cd1,drive=drive_cd1,bootindex=1,bus=ide.0,unit=0 \
    -device usb-tablet,id=usb-tablet1,bus=usb1.0,port=1  \
    -spice port=3000,password=123456,addr=0,image-compression=auto_glz,zlib-glz-wan-compression=auto,streaming-video=all,agent-mouse=on,playback-compression=on,ipv4  \
    -rtc base=localtime,clock=host,driftfix=slew  \
    -boot order=cdn,once=c,menu=off,strict=off \
    -enable-kvm
2. when it boots up ,after a while ,windows got the bsod

Actual results:

windows got bsod with error CLOCK WATCHDOG TIMEOUT

Expected results:
windows should work fine

Additional info:
1.cpu info

processor	: 31
vendor_id	: AuthenticAMD
cpu family	: 21
model		: 1
model name	: AMD Opteron(TM) Processor 6272                 
stepping	: 2
microcode	: 0x6000626
cpu MHz		: 2100.033
cache size	: 2048 KB
physical id	: 1
siblings	: 16
core id		: 7
cpu cores	: 8
apicid		: 79
initial apicid	: 47
fpu		: yes
fpu_exception	: yes
cpuid level	: 13
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt pdpe1gb rdtscp lm constant_tsc rep_good nopl nonstop_tsc extd_apicid amd_dcm aperfmperf pni pclmulqdq monitor ssse3 cx16 sse4_1 sse4_2 popcnt aes xsave avx lahf_lm cmp_legacy svm extapic cr8_legacy abm sse4a misalignsse 3dnowprefetch osvw ibs xop skinit wdt lwp fma4 nodeid_msr topoext perfctr_core perfctr_nb arat cpb hw_pstate npt lbrv svm_lock nrip_save tsc_scale vmcb_clean flushbyasid decodeassists pausefilter pfthreshold


2.virtio_win

virtio-win-1.8.0-4.iso
Comment 2 Yang Meng 2015-11-03 04:08:14 EST
SORRY ,the error should be "DPC_WATCHDOG_VIOLATION" ,you can check the screenshot
Comment 3 Vadim Rozenfeld 2015-11-05 02:39:57 EST
Can you please upload the relevant crash dump file?

Thanks,
Vadim.
Comment 4 Yang Meng 2015-11-05 03:29:14 EST
(In reply to Vadim Rozenfeld from comment #3)
> Can you please upload the relevant crash dump file?
> 
> Thanks,
> Vadim.

sorry ,don't see the crash dump file,can't login to the guest then.
Comment 5 Vadim Rozenfeld 2015-11-05 03:57:23 EST
(In reply to Yang Meng from comment #4)
> (In reply to Vadim Rozenfeld from comment #3)
> > Can you please upload the relevant crash dump file?
> > 
> > Thanks,
> > Vadim.
> 
> sorry ,don't see the crash dump file,can't login to the guest then.

I see, but can you use guestfish to access the guest image and copy pagefile.sys?

Thanks,
Vadim.
Comment 6 Yang Meng 2015-11-09 02:14:42 EST
(In reply to Vadim Rozenfeld from comment #5)
> (In reply to Yang Meng from comment #4)
> > (In reply to Vadim Rozenfeld from comment #3)
> > > Can you please upload the relevant crash dump file?
> > > 
> > > Thanks,
> > > Vadim.
> > 
> > sorry ,don't see the crash dump file,can't login to the guest then.
> 
> I see, but can you use guestfish to access the guest image and copy
> pagefile.sys?
> 
> Thanks,
> Vadim.

hi , sorry , i can't find the images now ,the machine which in beaker has been released for it has reached the reserved time, i am now trying to reproduce it,thanks.
Comment 7 Gu Nini 2015-11-17 02:51 EST
Created attachment 1095232 [details]
debug.tar.gz-RHEL7.1z_host
Comment 8 Gu Nini 2015-11-17 02:59 EST
Created attachment 1095233 [details]
pagefile.sys.tar.gz

(In reply to Vadim Rozenfeld from comment #5)

> I see, but can you use guestfish to access the guest image and copy
> pagefile.sys?
> 
> Thanks,
> Vadim.


I met a similar problem on RHEL7.1z host, the win2012 x86_64 r2 GUEST bsod for 'CLOCK WATCHDOG TIMEOUT'; attached is the pagefile.sys, for detail about the error info, please refer to screenshots in dir 'screendumps_virt-tests-vm1_14445_iter1' of attachment 'debug.tar.gz-RHEL7.1z_host'.

The software versions of host:
3.10.0-229.24.2.el7.x86_64
qemu-kvm-rhev-2.1.2-23.el7_1.10.x86_64
Comment 9 Vadim Rozenfeld 2015-11-17 03:50:24 EST
(In reply to Gu Nini from comment #8)
> Created attachment 1095233 [details]
> pagefile.sys.tar.gz
> 
> (In reply to Vadim Rozenfeld from comment #5)
> 
> > I see, but can you use guestfish to access the guest image and copy
> > pagefile.sys?
> > 
> > Thanks,
> > Vadim.
> 
> 
> I met a similar problem on RHEL7.1z host, the win2012 x86_64 r2 GUEST bsod
> for 'CLOCK WATCHDOG TIMEOUT'; attached is the pagefile.sys, for detail about
> the error info, please refer to screenshots in dir
> 'screendumps_virt-tests-vm1_14445_iter1' of attachment
> 'debug.tar.gz-RHEL7.1z_host'.
> 
> The software versions of host:
> 3.10.0-229.24.2.el7.x86_64
> qemu-kvm-rhev-2.1.2-23.el7_1.10.x86_64

Thanks a lot.
Unfortunately I have some problem extracting debug.tar.gz-RHEL7.1z_host
pagefile.sys.tar.gz also seems to be broken.
How did you acquire both of them? The simplest way is to do it with guestfis,
or by mounting a VM system image as a data (secondary) volume to another Windows VM.

Vadim.
Comment 10 Gu Nini 2015-11-23 02:38:19 EST
(In reply to Vadim Rozenfeld from comment #9)
......
> 
> Thanks a lot.
> Unfortunately I have some problem extracting debug.tar.gz-RHEL7.1z_host
> pagefile.sys.tar.gz also seems to be broken.
> How did you acquire both of them? The simplest way is to do it with guestfis,
> or by mounting a VM system image as a data (secondary) volume to another
> Windows VM.
> 
> Vadim.

Vadim, you can download the attachments then extract them with cmd 'tar zxvf ...'. If still some problem, please feel free to contact me.
Comment 11 Gu Nini 2016-01-06 05:41:50 EST
Vadim,

The issue in comment #8 is in fact bz 1271454 problem, and it's found the 2 bugs are similar, can you help to check the 2 bugs with the info provided? If any help, please inform us.

Thanks,

Nini
Comment 13 Vadim Rozenfeld 2016-06-27 22:42:20 EDT
(In reply to Gu Nini from comment #11)
> Vadim,
> 
> The issue in comment #8 is in fact bz 1271454 problem, and it's found the 2
> bugs are similar, can you help to check the 2 bugs with the info provided?
> If any help, please inform us.
> 
> Thanks,
> 
> Nini

Hi Gu Nini,

Seems like bz 1271454 (CLOCK_WATCHDOG_TIMEOUT issue) is not reproducible any more. I asked far the status update at https://bugzilla.redhat.com/show_bug.cgi?id=1271454#c5

Regarding to DPC_WATCHDOG_VIOLATION BSOD. Can you reproduce it? 
If yes, could you please share the latest crash dump files?

Thanks,
Vadim.

Note You need to log in before you can comment on or make changes to this bug.