Bug 127742 - File modes/permissions, owner, group owner ignored
Summary: File modes/permissions, owner, group owner ignored
Status: CLOSED DUPLICATE of bug 126231
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Configuration Management   
(Show other bugs)
Version: unspecified
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bret McMillan
QA Contact: Fanny Augustin
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 123188
TreeView+ depends on / blocked
 
Reported: 2004-07-13 08:23 UTC by Dean Samuels
Modified: 2007-10-24 02:36 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:04:25 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Dean Samuels 2004-07-13 08:23:40 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7)
Gecko/20040707 Firefox/0.9.2

Description of problem:
When assigned permissions and/or owner and/or group owner to files
being provisioned via RHN Satellite web console, the settings are
ignored and all files end up with mode 755, owner=root and group=root.

Version-Release number of selected component (if applicable):
rhncfg-client-3.1.6-12

How reproducible:
Always

Steps to Reproduce:
1. Set perms/mode and/or owner and/or group owner via RHN satellite
web console
2. Run rhncfg-client get <file> on client machine
3. Run ls -l <file> to verify metadata
    

Actual Results:  File permission, owner and group set to rwxr-xr-x,
root, root respectively

Expected Results:  File permission, owner and group should correspond
to settings made via RHN satellite web console under config channel
management

Additional info:

Client is installed on RHEL3 systems.

Comment 1 Chip Turner 2004-07-13 10:43:08 UTC
I also saw some possibly related behavior in the UI yesterday.  Imported files had screwey 
filemode.  We need to do a full audit to ensure the file metadata is correctly being 
imported and exported by the config system and tighten up some of the cases where it is 
not behaving properly.

Comment 2 Bret McMillan 2004-07-13 13:09:28 UTC
Mode issue has already been addressed as part of another bug.

*** This bug has been marked as a duplicate of 126231 ***

Comment 3 Red Hat Bugzilla 2006-02-21 19:04:25 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.