Bug 1277452 - Failed to import virtual machine when select VMware as source on rhevm3.6 server
Failed to import virtual machine when select VMware as source on rhevm3.6 server
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.6.0
x86_64 Unspecified
medium Severity medium
: ovirt-3.6.1
: ---
Assigned To: Shahar Havivi
Nisim Simsolo
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-03 06:07 EST by zhoujunqin
Modified: 2016-04-19 21:10 EDT (History)
16 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-19 21:10:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Virt
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot-1 for step2 (159.79 KB, image/png)
2015-11-03 06:07 EST, zhoujunqin
no flags Details
vdsm.log (953.13 KB, text/plain)
2015-11-03 06:12 EST, zhoujunqin
no flags Details
engine.log (15.97 KB, text/plain)
2015-11-03 06:13 EST, zhoujunqin
no flags Details
screenshot-2 (340.40 KB, image/png)
2015-12-09 05:25 EST, zhoujunqin
no flags Details
engine.log for comment 6 (119.03 KB, text/plain)
2015-12-09 23:12 EST, zhoujunqin
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 48059 None None None Never
oVirt gerrit 48322 ovirt-engine-3.6 MERGED engine: v2v is not handling 32bit vms Never

  None (edit)
Description zhoujunqin 2015-11-03 06:07:28 EST
Created attachment 1088913 [details]
screenshot-1 for step2

Description of problem:
when i test virt-v2v integration to rhevm feature, failed to import virtual machine when select VMware as source on rhevm3.6 server

Version-Release number of selected component (if applicable):
1.
rhevm server: rhevm-3.6.0.2-0.1.el6.noarch
2.
registered host installed with following tree:http://download.englab.nay.redhat.com/pub/rhel/rel-eng/RHEL-7.2-20151030.0/compose/Server/x86_64/os/

libvirt-1.2.17-13.el7.x86_64
vdsm-4.17.10-5.el7ev.noarch
libguestfs-1.28.1-1.55.el7.x86_64
virt-v2v-1.28.1-1.55.el7.x86_64
qemu-kvm-rhev-2.3.0-31.el7.x86_64


How reproducible:
100%

Steps to Reproduce:
1. Login with administration portal, System->Virtual Machines. 
2. Click Import. Select VMware as source  and complete details for my vCenter environment.
Details please see screenshot-1
3. Click the "Load" button.

Actual results:
Get a error message from webadmin and The "Import Virtual Machine(s)" window hangs forever.
Failed to retrieve VMs information from external server vpx://root@10.66.4.103/tzheng-demo/10.66.106.63?no_verify=1


Expected results:
list of VM's available for import.

Additional info:
1. virsh command works well.

# virsh -c vpx://root@10.66.4.103/tzheng-demo/10.66.106.63?no_verify=1
Enter root's password for 10.66.4.103: 
Welcome to virsh, the virtualization interactive terminal.

Type:  'help' for help with commands
       'quit' to quit

virsh # list 
 Id    Name                           State
----------------------------------------------------


2. I will attach engine.log and vdsm.log
Comment 1 zhoujunqin 2015-11-03 06:12 EST
Created attachment 1088915 [details]
vdsm.log
Comment 2 zhoujunqin 2015-11-03 06:13 EST
Created attachment 1088916 [details]
engine.log
Comment 4 zhoujunqin 2015-12-09 05:24:49 EST
Tried with new rhevm pkg and import virtual machine while selecting VMware as source, but failed, please help me have a look.

steps:
1. Upgrade my rhevm server to latest one:
rhevm-3.6.1.1-0.1.el6.noarch

2. Login with administration portal, System->Virtual Machines. 

3. Click Import. Select VMware as source  and complete details for my vCenter environment.

4. Click the "Load" button.

5. Choose one virtual machine to import, and click "Next".(See screenshot-2).

6. Click "OK" in next window.

Result:
After step6,failed to import guest with error:

Error while executing action:

esx6.0-rhel6.7-i386:

    Cannot ${action} ${type}. Host does not exist.
Comment 5 zhoujunqin 2015-12-09 05:25 EST
Created attachment 1103821 [details]
screenshot-2
Comment 6 Shahar Havivi 2015-12-09 05:36:37 EST
you need to select host in the "proxy host" select box
Comment 7 Shahar Havivi 2015-12-09 07:44:35 EST
The can do action message is fixed and will be merged in 3.6.2
Please see if you have active hots in the cluster,
If it still doesn't work please attach the engine log.
Comment 8 zhoujunqin 2015-12-09 23:11:23 EST
(In reply to Shahar Havivi from comment #6)
> you need to select host in the "proxy host" select box

Yes, when i selected the registered host in "proxy host", i can not meet Comment 4 error in next page.

But i always have some issue want to confirm with you.

1. When my registered host is  a latest rhel7.2 host, i can import a virtual machine from esx server(VMware as source) successfully .

2. When my registered host is a rhevh 7.2 system, failed to import guest from esx server and ova file with following error:

Failed to import Vm esx6.0-rhel5.11-x86_64 to Data Center Default, Cluster Default

I will attach engine.log, called engine.log_cmt6.

please help me have a look, thanks in advance.
Comment 9 zhoujunqin 2015-12-09 23:12 EST
Created attachment 1104208 [details]
engine.log for comment 6
Comment 10 Shahar Havivi 2015-12-10 03:02:22 EST
It looks like the original problem that you open this bug for is solved since you are able to list the vms now.

Please contact me offline for this issue and will decide if this is a new bug.
Comment 11 zhoujunqin 2015-12-10 22:05:27 EST
(In reply to Shahar Havivi from comment #10)
> It looks like the original problem that you open this bug for is solved
> since you are able to list the vms now.
> 
> Please contact me offline for this issue and will decide if this is a new
> bug.

ok, since bug issue has been fixed, i will contact you offline, thanks very much.
Comment 13 Nisim Simsolo 2016-01-20 06:31:44 EST
Verified: 
rhevm-3.6.2.5-0.1.el6
sanlock-3.2.4-1.el7.x86_64
vdsm-4.17.17-0.el7ev.noarch
libvirt-client-1.2.17-13.el7_2.2.x86_64
qemu-kvm-rhev-2.3.0-31.el7_2.4.x86_64

Note You need to log in before you can comment on or make changes to this bug.