Bug 1277455 - KVM over IP Switch Java applet is not working
KVM over IP Switch Java applet is not working
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: icedtea-web (Show other bugs)
7.2
x86_64 Linux
unspecified Severity low
: rc
: ---
Assigned To: jiri vanek
BaseOS QE - Apps
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-03 06:17 EST by Oliver Haessler
Modified: 2015-11-06 09:43 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-05 07:23:11 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Oliver Haessler 2015-11-03 06:17:52 EST
Description of problem:
When accessing a KVM over IP Switch and try to use the console it fails an error message.

Version-Release number of selected component (if applicable):
firefox-38.3.0-2.el7_1.x86_64
icedtea-web-1.6.1-4.el7.x86_64
java-1.8.0-openjdk-1.8.0.65-3.b17.el7.x86_64

How reproducible:
Every time you try to open the console.

Steps to Reproduce:
1. Log in to the KVM management web site
2. Connect to a port of the KVM

Actual results:
Error message is shown:

-----
net.sourceforge.jnlp.LaunchException: Fatal: Initialization Error: Could not initialize application. The application has not been initialized, for more information execute javaws from the command line.
	at net.sourceforge.jnlp.Launcher.createApplication(Launcher.java:813)
	at net.sourceforge.jnlp.Launcher.launchApplication(Launcher.java:532)
	at net.sourceforge.jnlp.Launcher$TgThread.run(Launcher.java:936)
Caused by: net.sourceforge.jnlp.LaunchException: Fatal: Initialization Error: Unknown Main-Class. Could not determine the main class for this application.
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.initializeResources(JNLPClassLoader.java:704)
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.<init>(JNLPClassLoader.java:285)
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.createInstance(JNLPClassLoader.java:357)
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.getInstance(JNLPClassLoader.java:429)
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.getInstance(JNLPClassLoader.java:403)
	at net.sourceforge.jnlp.Launcher.createApplication(Launcher.java:805)
	... 2 more
-----

Expected results:
KVM Java console should be opened

Additional info:
The Console is working without issues with java-1.8.0-oracle-plugin-1.8.0.65-1jpp.3.el7_1.x86_64 and java-1.8.0-oracle-1.8.0.65-1jpp.3.el7_1.x86_64
Comment 5 jiri vanek 2015-11-05 07:22:59 EST
So. Tehre is an bug  in this jnlp file (please always provide jnlp fiel when there is jnnlp fiel involved)

<application-desc main-class=" com.main.Main">

It is very wrong.  The class " com.main.Main" do not exists, so ITW is right about it.

But "com.main.Main" class do exists.

So if you fix downloaded file (remove leading space before com)  you will be able to lunch this app as it is.


This is old knownbug, but for security reasons this behaviour will not be fixed.

Authors of this jnlp file MUST fix it (== provide VALID main class) 


For future TIW I will probably add warning about sapce in main class and/or runtime argument to fix it. But it can not be made as default.

Note You need to log in before you can comment on or make changes to this bug.