This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1277475 - heketi volume mount options: backupvolfile-server should list only a single server
heketi volume mount options: backupvolfile-server should list only a single s...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: heketi (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Michael Adam
Anush Shetty
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-03 07:31 EST by Anush Shetty
Modified: 2017-01-03 05:50 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-01-03 05:50:11 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anush Shetty 2015-11-03 07:31:11 EST
Description of problem: The volume info currently lists n-1 servers as backupvolfile-servers. The backupvolfile-server mount option expects only one value, and not a comma-separated set of values.


Version-Release number of selected component (if applicable): heketi-devel-1.0.0-1.el7rhgs.noarch


How reproducible: Always


Steps to Reproduce:
1. Create a heketi volume
2. The output of a volume creation command successfully executed has the mount options value
3.

Actual results:

Mount Options: backupvolfile-servers=rhshdp03.lab.eng.blr.redhat.com,rhshdp04.lab.eng.blr.redhat.com,rhshdp06.lab.eng.blr.redhat.com,rhshdp13.lab.eng.blr.redhat.com

When I try to mount it, I get the following error:

mount -t glusterfs -o backupvolfile-server=rhshdp03.lab.eng.blr.redhat.com,rhshdp04.lab.eng.blr.redhat.com,rhshdp06.lab.eng.blr.redhat.com,rhshdp13.lab.eng.blr.redhat.com rhshdp05.lab.eng.blr.redhat.com:vol_20363034cdd3439f675d6db92da6bb3b /mnt/

Invalid option rhshdp04.lab.eng.blr.redhat.com
Comment 2 Luis Pabón 2015-11-03 08:17:02 EST
Anush, Since this is an interface to services and not to users, Heketi provides services with all possible choices for backupvolfile-servers. It is up to the service to show the user the correct service choice.

Does that make sense?
Comment 3 Anush Shetty 2015-11-04 01:59:05 EST
(In reply to Luis Pabón from comment #2)
> Anush, Since this is an interface to services and not to users, Heketi
> provides services with all possible choices for backupvolfile-servers. It is
> up to the service to show the user the correct service choice.
> 
> Does that make sense?

It does, though it would be useful to just pull it off as is to run a mount command. Also, the output format is similar to the mount option syntax. So it could be confusing unless we clearly mention it?
Comment 4 Luis Pabón 2015-11-20 10:48:34 EST
Updated the API spec file.

https://github.com/heketi/heketi/wiki/API#volume_info
Comment 5 Anush Shetty 2015-11-24 07:01:49 EST
Marking this as verified.

Note You need to log in before you can comment on or make changes to this bug.