Bug 1277483 - Total RX/TX statistics are not cleared and reported when a VM is moved from a compatible cluster to an incompatible cluster
Total RX/TX statistics are not cleared and reported when a VM is moved from ...
Status: CLOSED NOTABUG
Product: ovirt-engine
Classification: oVirt
Component: BLL.Network (Show other bugs)
3.6.0
x86_64 Linux
unspecified Severity low (vote)
: ---
: ---
Assigned To: Dan Kenigsberg
Michael Burman
network
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-03 07:49 EST by Michael Burman
Modified: 2016-02-10 14:57 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-11 05:13:30 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
mburman: planning_ack?
mburman: devel_ack?
mburman: testing_ack?


Attachments (Terms of Use)

  None (edit)
Description Michael Burman 2015-11-03 07:49:18 EST
Description of problem:
Total RX/TX statistics are not cleared and reported when a  VM is moved from a compatible cluster to an incompatible cluster.

- From http://www.ovirt.org/Features/Cumulative_RX_TX_Statistics feature page:
"Total RX/TX statistics are cleared (not reported) when: 
 A VM is moved from a compatible cluster to an incompatible cluster. "

But currently when moving VM to cluster 3.5, the RX/TX statistics are not cleared as they should.

Version-Release number of selected component (if applicable):
3.6.0.2-0.1.el6

How reproducible:
100

Steps to Reproduce:
1. Run VM on cluster 3.6 (RX/TX statistics reported)
2. Stop VM 
3. Move VM to cluster 3.5
4. Verify that RX/TX statistics are cleared and not reported.

Actual results:
Total RX/TX statistics are not cleared and reported

Expected results:
Total RX/TX statistics are cleared (not reported).
Comment 1 Michael Burman 2015-11-03 08:48:39 EST
Statistics will be cleared only when the VM will run on cluster 3.5
Comment 2 Yaniv Lavi 2015-11-11 05:13:30 EST
This seems like more of a feature to me than a bug, since you can still keep the stats if you don't run the vm after move.
Comment 3 Michael Burman 2015-11-11 05:19:03 EST
- From http://www.ovirt.org/Features/Cumulative_RX_TX_Statistics feature page:
"Total RX/TX statistics are cleared (not reported) when: 
 A VM is moved from a compatible cluster to an incompatible cluster. "

Note You need to log in before you can comment on or make changes to this bug.