Bug 1277535 - machines reported by virt-who are processed very slow (~1s/each)
machines reported by virt-who are processed very slow (~1s/each)
Status: CLOSED WONTFIX
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Performance (Show other bugs)
6.0.0
x86_64 Linux
unspecified Severity high (vote)
: GA
: --
Assigned To: Tom McKay
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-03 09:13 EST by Marcel Gazdík
Modified: 2017-04-25 12:29 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-02-07 13:12:54 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 3 Radek Novacek 2015-11-05 01:47:48 EST
Mike, I don't see anything that can virt-who do about it. It just gets the data and pushes them to the Satellite, but it doesn't get a response back and the socket times out.

I think that Satellite has asynchronous report processing that should help here. But I don't know in what version and how to enable it. Nevertheless latest virt-who supports it.

Switching back to Satellite.
Comment 4 Marcel Gazdík 2015-11-05 02:31:40 EST
Ad #3, Radek is correct, the data are gathered and sent correctly and fast, the issue is on the satellite site, maybe the dynflow_executor takes only one task per second? And the main issue is maybe not the time it takes, but the resulting deadlocks in the database when you have multiple reporters for multiple vCenters in a dynamic environment.
Comment 10 Bryan Kearney 2017-02-07 13:12:54 EST
I am closing this out based on improvements made in 6.2. If you are still seeing performance issues on 6.2 please feel free to re-open with additional data.

Note You need to log in before you can comment on or make changes to this bug.